2015南阳CCPC L - Huatuo's Medicine 水题

L - Huatuo's Medicine

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

Description





Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these bottles together.

However, there was a critical problem. When Huatuo arrived the patient's home, he took the chain out of his bag, and he could not recognize which bottle contains which type of medicine, but he remembers the order of the bottles on the chain.

Huatuo has his own solution to resolve this problem. When he need to bring 2 types of medicines, E.g. A and B, he will put A into one bottle and put B into two bottles. Then he will chain the bottles in the order of -B-A-B-. In this way, when he arrived the patient's home, he knew that the bottle in the middle is medicine A and the bottle on two sides are medicine B.

Now you need to help Huatuo to work out what's the minimal number of bottles needed if he want to bring N types of medicine.



Input

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the minimal number of bottles Huatuo needed.

Output

For each test case, output one line containing Case #x:, where x is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.

Sample Input

1
2

Sample Output

Case #1: 3

HINT

 

题意

华佗有n种药,让你构成一条最短的链,他能够在黑暗中也能找到自己想找到的药品

题解:

对称就好了,例如:D-C-B-A-B-C-D

所以答案2n-1

代码:

#include<iostream>
#include<stdio.h>
using namespace std;


int main()
{
    int t;scanf("%d",&t);
    for(int cas = 1;cas <= t;cas ++)
    {
        int n;scanf("%d",&n);
        printf("Case #%d: %d\n",cas,2*n-1);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值