HDU 4091 Zombie’s Treasure Chest(2011ACM上海赛区预选赛第一题)

Zombie’s Treasure Chest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 994    Accepted Submission(s): 211


Problem Description
  Some brave warriors come to a lost village. They are very lucky and find a lot of treasures and a big treasure chest, but with angry zombies.
  The warriors are so brave that they decide to defeat the zombies and then bring all the treasures back. A brutal long-drawn-out battle lasts from morning to night and the warriors find the zombies are undead and invincible.
  Of course, the treasures should not be left here. Unfortunately, the warriors cannot carry all the treasures by the treasure chest due to the limitation of the capacity of the chest. Indeed, there are only two types of treasures: emerald and sapphire. All of the emeralds are equal in size and value, and with infinite quantities. So are sapphires.
  Being the priest of the warriors with the magic artifact: computer, and given the size of the chest, the value and size of each types of gem, you should compute the maximum value of treasures our warriors could bring back.
 

 

Input
  There are multiple test cases. The number of test cases T (T <= 200) is given in the first line of the input file. For each test case, there is only one line containing five integers N, S1, V1, S2, V2, denoting the size of the treasure chest is N and the size and value of an emerald is S1 and V1, size and value of a sapphire is S2, V2. All integers are positive and fit in 32-bit signed integers.
 

 

Output
  For each test case, output a single line containing the case number and the maximum total value of all items that the warriors can carry with the chest.
 

 

Sample Input
2 100 1 1 2 2 100 34 34 5 3
 

 

Sample Output
Case #1: 100 Case #2: 86
 

 

Source
 

 

Recommend
lcy
 
 
 
#include<stdio.h>
#include<algorithm>
using namespace std;
long long gcd(long long da,long long xiao)
{
long long temp;
while(xiao!=0)
{
temp=da%xiao;
da=xiao;
xiao=temp;
}
return da;
}
int main()
{
int iCase=0;
int T;
scanf("%d",&T);
long long N,S1,V1,S2,V2;
while(T--)
{
iCase++;
scanf("%I64d%I64d%I64d%I64d%I64d",&N,&S1,&V1,&S2,&V2);
long long tmp=S1*S2/gcd(S1,S2);
long long res;
long long tt=N/tmp;
N=N%tmp;
if(tt)
{
tt--;
N+=tmp;
}
res=max((tt)*(tmp/S1)*V1,(tt)*(tmp/S2)*V2);
long long res2=0;
if(S2>S1)
{
long long t;
t=S1;S1=S2;S2=t;
t=V1;V1=V2;V2=t;
}
for(int i=0;i<=N/S1;i++)
{
if(res2<i*V1+(N-i*S1)/S2*V2)res2=i*V1+(N-i*S1)/S2*V2;
}
res+=res2;
printf("Case #%d: %I64d\n",iCase,res);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值