[ACM]Max Sum

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
 
  
Case 1: 14 1 4 Case 2: 7 1 6


代码:

#include <iostream>
using namespace std;
int a[100002];//用来存放数字
int main()
{
    int T,N,i,j;
    cin>>T;
    for(i=1;i<=T;i++)
    {
        cin>>N;
        for(j=0;j<N;j++)
            cin>>a[j];
        int start=0,end=0,sum=0,s=0,e,max;//start起始位置,end结尾位置,sum为连续数字的和,s为起始位置变量,和start有关,e为结尾位置变量,max为所求的最大值
        max=a[0];
        for(j=0;j<N;j++)
        {
            e=j;//记录运算到得位置,也是末位置
            sum=sum+a[j];
            if(sum>max)
            {
                max=sum;
                start=s;
                end=e;
            }
            if(sum<0)//这里写成sum+a[j]<a[j]比较好理解,sum为负数,舍去前边的,从下一位开始从头运算
            {
                s=j+1;//记录新运算的起始位置
                sum=0;
            }
        }
        cout<<"Case "<<i<<":"<<endl;
        cout<<max<<" "<<start+1<<" "<<end+1<<endl;
        if(i<=T-1)
            cout<<endl;//注意格式

    }
    return 0;
}


运行截图:


转载于:https://www.cnblogs.com/sr1993/archive/2013/06/03/3697855.html

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值