练习三 Problem A

原题:

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).<br>

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6


题目大意:求最大的连续字段和,求出并输出该子段和的起始位置。


解题思路:输入一串整数,记一个最大和summax,使其不断与前i个数的和比较若sum[i]>summax并记录开始与结束的位置,则使summax=sum[i];若sum[i]<0,则sum[i]=0并记录此时的位置为起始位置;此后不断循环最终得到所求结果。注意起始位置的记录。


感想:经典dp题,新手必做,刚开始的时候做还是有点困难。


代码:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int n,t,i,c;
    int a[100002];
    scanf("%d",&t);
    for(c=1;c<=t;c++)
    {
        int k=1,st=0,en=0,summax=-1000,sum=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=0;i<n;i++)
        {
            sum+=a[i];
            if(sum>summax)
            {
                summax=sum;
                st=k;
                en=i+1;
            }
            if(sum<0)
            {
                sum=0;
                k=i+2;
            }
        }
        printf("Case %d:\n%d %d %d\n",c,summax,st,en);
        if(c!=t) cout<<endl;
    }
    return 0;
}


  • 3
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 7
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值