POJ3461:Oulipo(MP,KMP裸题)

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39112 Accepted: 15748

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

题意:求一个串在另一个串中出现的次数。

思路:

①MP算法,区别于BF算法那样的暴力循环,当遇到不匹配的字符时,不需要回到模式串的开头重新匹配,只需从next处继续即可,如下图:遇到a和b不等,但黑色部分A和B是一样的话,直接从A的右边处继续匹配,next数组需要预处理。


# include <stdio.h>
# include <string.h>
char s[10001], t[1000001];
int next[10001];//失配指针
int slen, tlen;

void init()
{
    memset(next, 0, sizeof(next));
    next[0] = next[1] = 0;
    for(int i=1; i<slen; ++i)
    {
        int j = next[i];
        while(j && s[i] != s[j]) j = next[j];
        next[i+1] = s[i]==s[j]?j+1:0;
    }
}

int kmp()
{
    int ans = 0, j = 0;
    for(int i=0; i<tlen; ++i)
    {
        while(j && t[i] != s[j]) j = next[j];
        if(t[i] == s[j]) ++j;
        if(j == slen)
        {
            ++ans;//计数器
            j = next[j];
        }
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",s,t);
        slen = strlen(s);
        tlen = strlen(t);
        init();
        printf("%d\n",kmp());
    }
    return 0;
}

②KMP实现:区别于MP,多开一个数组用于优化,失配指针更精确。

# include <stdio.h>
# include <string.h>
char s[10001], t[1000001];
int next[10001];//优化后的失配指针
int next2[10001];//原来的失配指针
int slen, tlen;

void init()
{
    memset(next, 0, sizeof(next));
    memset(next2, 0, sizeof(next2));
    next[0] = next[1] = 0;
    next2[0] = next2[1] = 0;
    for(int i=1; i<slen; ++i)
    {
        int j = next2[i];
        while(j && s[i] != s[j]) j = next[j];
        next2[i+1] = next[i+1] = s[i]==s[j]?j+1:0;
        if(next[i+1]==j+1 && s[i+1]==s[j+1])//这种情况下,指针可以继续往前跳。
            next[i+1] = next[j+1];
    }
}

int kmp()
{
    int ans = 0, j = 0;
    for(int i=0; i<tlen; ++i)
    {
        while(j && t[i] != s[j]) j = next[j];
        if(t[i] == s[j]) ++j;
        if(j == slen)
        {
            ++ans;//计数器
            j = next[j];
        }
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",s,t);
        slen = strlen(s);
        tlen = strlen(t);
        init();
        printf("%d\n",kmp());
    }
    return 0;
}


转载于:https://www.cnblogs.com/junior19/p/6729925.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值