zcmu 1893: String Game

http://acm.zcmu.edu.cn/JudgeOnline/problem.php?id=1893

1893: String Game

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 55   Solved: 20
[ Submit][ Status][ Web Board]

Description

Alice and Bob are playing the following game with strings of letters.

Before the game begins, an initial string and a target string are decided. The initial string is at least as long as the target string. Then, Alice and Bob take turns, starting with the initial string. Bob goes first. In each turn, the current player removes either the first or the last letter of the current string. Once the length of the current string becomes equal to the length of the target string, the game stops. If the string at the end of the game is equal to the target string, Alice wins the game; otherwise Bob wins.

Determine who will win the game if both players are playing optimally.

Input

Each test case starts with  N , the number of inputs to process. Each input consists of one line, which contains the initial string, followed by a space, followed by the target string. Each string consists of only lowercase letters. The total input length will be less than 500000 characters.

Output

For each input, output the winner, which will either be Alice  or Bob .

Sample Input

5
aba b
bab b
aaab aab
xyz mnk
xyz xyz

Sample Output

Alice
Alice
Bob
Bob
Alice


大致题意是:每回合每人可以删去字符串a的第一个或者最后一个字符,直到a的长度等于b的长度,此时若a=b,则
Alice胜。Bob先走。
Alice胜的情况:
1.很明显,如果b正好在a的中间,那么无论Bob删哪边,Alice删另一侧就可以了;
2.如果在b不a的中间,Alice先和Bob删异侧的,直达遇到b,假设此时的a是(b)...,那么如果b的后面有一或二 个字符,就可以在之前的Bob删a的最后一个字符的某次和Bob删同侧的,这样最后一回合的时候就会变成x(b)y【x,y代表一个字符】,则Alice胜;但是Bob可能一直删a的第一个字符,所以同理当 Bob 只删a的第一个字符时,应出现...(b)【b的前面只有一或二个字符】。
    综上:b不a的中间时,若 删去 a的第一个字符 an-bn为奇数 】(或前两个字符【an-bn为 偶数】) 或者删去a的最后 一个字符【an-bn为奇数】(或最后两个字符【an-bn为 偶数】) 能使b在a的中间,则Alice胜。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#define maxn 500055

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        char a[maxn],b[maxn];
        scanf("%s%s",a,b);
        int an=strlen(a),bn=strlen(b),flag=0;
        int d=(an-bn)/2;
        if((an-bn)%2)
        {
            if(strncmp(a+d+1,b,bn)==0&&strncmp(a+d,b,bn)==0)
                flag=1;
        }
        else
        {
            if(strncmp(a+d,b,bn)==0)
                flag=1;
            else{
                if(strncmp(a+d+1,b,bn)==0&&strncmp(a+d-1,b,bn)==0)
                {flag=1;}
            }
        }
        if(flag)
            printf("Alice\n");
        else
            printf("Bob\n");
    }
    return 0;
}



转载于:https://www.cnblogs.com/107acm/p/9428342.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: zcmu 1093 简单计算器是一道编程题目,要求实现一个简单的计算器,能够进行加、减、乘、除四种基本运算。该题目主要考察编程基础能力和算法思维能力,需要熟练掌握基本的运算符和控制语句,能够设计合理的算法实现计算器功能。 ### 回答2: zcmu 1093 简单计算器是一种基于计算机技术的工具,用于进行基本算术运算,如加减乘除等。它能够简化我们在日常生活中的计算工作,提高计算效率,减少出错率。 使用zcmu 1093 简单计算器非常简单,只需输入需要计算的数字和符号,就能够得到计算结果。它可以进行多个数字之间的复杂运算,同时还支持小数、百分数、平方根等复杂运算。另外,zcmu 1093 简单计算器还可以存储中间计算结果,方便我们进行多步计算或调整计算过程。 除了日常的计算工作,zcmu 1093 简单计算器还可用于科学计算、工程设计等领域。许多专业软件都是基于简单计算器原理设计的,它们具有更高的计算精度和更复杂的运算能力,能够支持更高级别的科学计算和技术分析。 总之,zcmu 1093 简单计算器在日常生活中有着广泛的应用,它使我们的计算工作变得更加高效、准确。并且,随着科技的不断发展,这种计算工具也在不断地更新和改进,为我们的计算工作提供更加便捷、多样化的选择。 ### 回答3: ZCMU 1093 简单计算器是一道基础的算法题目,需要实现一个简单的计算器程序,支持加、减、乘、除四种基本运算,可以对两个整数进行运算并输出结果。 要实现这道题目,首先需要根据输入的运算符来判断应该进行的运算类型,并根据运算符的不同,执行不同的计算操作。同时,应注意除数不能为零的情况,避免程序出现异常。 在编写程序的过程中,可以使用 switch case 语句来判断不同的运算类型,并执行相应的计算操作。同时,为了能有效地判断输入的运算符,可以使用输入字符串的方式进行处理,提取出运算符进行比较。 此外,在程序中还需要进行合法性判断,确保输入的数字均为整数且在合理的范围内,以避免程序运行出现异常情况。同时,还需要考虑输入格式的问题,应确保输入的数字和运算符符合题目要求。 综上所述,ZCMU 1093 简单计算器是一道基础的算法题目,需要实现一个简单的计算器程序,支持加、减、乘、除四种基本运算,注意程序的合法性判断和输入格式的处理,能够熟练地运用 switch case 等语句完成程序的编写。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值