hdu1074 Doing Homework(状态压缩DP Y=Y)

 

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3958    Accepted Submission(s): 1577

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

 

Sample Input
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

 

Sample Output
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
 

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1074

分析: 状态压缩, 用二进制表示状态,1表示有,0表示没有。 

         f[1<<n-1] 表示最终状态 二进制位上全为1。

         此题难点在于找到前一个状态来推当前要计算的状态。

         当然也容易知道 ,对于一个状态f[S]它的前一个状态为f[Ki],  {Ki在二进制位下比S少一个1}


#include <stdio.h>
#include <string.h>
#define MAXN 16
#define INF 0x7fffffff
struct tt {
    int time, deadline;
    char name[105];
} hw[MAXN];

struct t {
    int pre, now;
    int score, time;
    t() {pre = -1;}
} dp[1 << MAXN];

void print(int k)
{
    if(dp[k].pre!=-1)
    {
        print(dp[k].pre);
        printf("%s\n", hw[ dp[k].now ].name );
    }
}
int main()
{
    int T, n, s, i, recent, past, reduce, j, max;
    scanf("%d", &T);
    while (T--) {
        scanf("%d", &n);
        for (i = 0; i < n; i++)
            scanf("%s %d %d", &hw[i].name, &hw[i].deadline, &hw[i].time);
        max = 1 << n;
        for (s = 1; s < max; s++) {
            dp[s].score = INF;
            for (i = n - 1; i >= 0; i--) {
                recent = 1 << i;
                if (s & recent) {
                    past = s - recent;
                    reduce = dp[past].time + hw[i].time - hw[i].deadline;
                    if (reduce < 0)
                        reduce = 0;
                    if (reduce + dp[past].score < dp[s].score) {
                        dp[s].score = dp[past].score + reduce;
                        dp[s].now = i;
                        dp[s].pre = past;
                        dp[s].time = dp[past].time + hw[i].time;
                    }
                }
            }
        }
        printf("%d\n", dp[max - 1].score);
        print(max-1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值