P2759 奇怪的函数

传送门

题目描述

使得 xxx^x xx达到或超过 n 位数字的最小正整数 x 是多少?

输入输出格式

输入格式:

一个正整数 n

输出格式:

使得 xxx^xxx 达到 n 位数字的最小正整数 x

输入输出样例

输入样例#1: 复制
11
输出样例#1: 复制
10

说明

n<=2000000000

#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstdio>
using namespace std;
long long n;
int main()
{
    cin>>n;
    long long l=1,r=2e9;
    while(l<r)
    {
        long long mid=(l+r)>>1;
        
        if((long long)(mid*log10(mid))+1<n)
        {
            l=mid+1;
        }
        else
        r=mid;
    }
    cout<<l;
}

 

转载于:https://www.cnblogs.com/JCRL/p/10160718.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值