绑定两台路由器之间的多条E1链路的方法有如下几种
1.硬件IMUX              2-8
2.ATM IMA               2-32
3.Multilink ppp          2-8
4.Load balancing          2-6
其中1、2为硬件解决方式,3、4为软件解决方式
PPP multilink配置方法:
interface Multilink1
ip address 1.1.1.1 255.255.255.252
no cdp enable
ppp multilink
no ppp multilink fragmentation
!--- optional command to reduce CPU load
multilink-group 1
interface Serial0/0:1
no ip address
encapsulation ppp
ppp multilink
multilink-group 1
interface Serial0/1:1
no ip address
encapsulation ppp
ppp multilink
multilink-group 1
Load balancing  方式:
(1): cef per-packet 方式
ip cef
int s0/0:1
ip add 1.1.1.1 255.255.255.252
ip load-sharing per-packet
int s0/1:1
ip add 2.2.2.1 255.255.255.252
ip load-sharing per-packet
(2): cef per-destination方式
ip cef
int s0/0:1
ip add 1.1.1.1 255.255.255.252
ip load-sharing per-destination
int s0/1:1
ip add 2.2.2.1 255.255.255.252
ip load-sharing per-destination
(3):fast swtiching per-destination方式
int s0/0:1
ip add 1.1.1.1 255.255.255.252
int s0/1:1
ip add 2.2.2.1 255.255.255.252
(4):Process swtiching per-packet方式
int s0/0:1
ip add 1.1.1.1 255.255.255.252
no ip route-cache
int s0/1:1
ip add 2.2.2.1 255.255.255.252
no ip route-cache
______________________________________________________
多个PPP线路绑定Multilink的实例
 
 
Router1:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname KSFCRT01
!
enable secret 5 $1$bHo9$DLEAPlCZMn.Qd/k.XGfqj1
!
username gncs privilege 15 password 7 030A5E1F0B0E2F5F4B0A0B0003
username fgnc password 7 071D3541410710111800
ip subnet-zero
!
!
no ip domain lookup
ip host SW01 23 10.102.4.12
ip host SW03 23 10.102.4.11
ip host SW02 23 10.102.0.11
ip host RT02 23 10.102.250.2
!
!
!
!
!
interface Loopback0
ip address 172.16.172.15 255.255.0.0
!
interface Multilink1
description to Customs channel 4*E1
ip address 10.102.250.1 255.255.255.252
ip accounting output-packets
ppp multilink
ppp multilink fragment-delay 20
ppp multilink interleave
multilink-group 1
!
interface FastEthernet0/0
description to Local 100M
ip address 10.102.4.1 255.255.252.0
ip accounting output-packets
duplex auto
speed auto
!
interface Serial0/0
description to Customs E1-01
bandwidth 1949
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial0/1
description to Customs E1-02
bandwidth 1949
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial0/2
description to Customs E1-03
bandwidth 1949
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial0/3
description to Customs E1-04
bandwidth 1949
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
router eigrp 64
passive-interface FastEthernet0/0
network 10.0.0.0
auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip route 10.99.6.97 255.255.255.255 10.102.4.10
ip route 10.99.7.9 255.255.255.255 10.102.4.10
no ip http server
!
!
access-list 99 permit 10.99.6.97
access-list 102 permit ip 10.102.4.0 0.0.3.255 any
access-list 102 permit ip host 10.127.3.1 any
access-list 102 permit ip host 10.99.6.97 any
access-list 102 permit ip host 10.97.13.2 any
access-list 102 permit ip host 10.98.7.45 any
snmp-server community fgncman RO 99
snmp-server enable traps tty
!
line con 0
password 7 011D0310560A081C244F5C0C0D
login local
line aux 0
exec-timeout 520 0
no exec
transport input all
line vty 0 4
password 7 0208014F06070132494D1B1C11
login local
!
!
end

Router2
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname KSFCRT02
!
enable secret 5 $1$M701$gSXqyzi5R7T3urLicjy5Q1
!
username foxconn privilege 15 password 7 06000039424B1D
memory-size iomem 30
ip subnet-zero
!
!
no ip domain lookup
!
!
!
!
!
interface Multilink1
ip address 10.254.11.194 255.255.255.252
ppp multilink
ppp multilink fragment-delay 20
ppp multilink interleave
multilink-group 1
!
interface FastEthernet0/0
ip address 10.102.0.1 255.255.252.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial0/1
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial0/2
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial0/3
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
router eigrp 100
network 10.0.0.0
auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
access-list 99 permit 10.99.6.97
access-list 99 permit 10.99.6.32
snmp-server community fgncman RO 99
snmp-server enable traps tty
!
line con 0
password 7 104806010B1206
login local
line aux 0
no exec
transport input all
line vty 0 4
password 7 03025413080A35
login local
!
!
end