hdu5372 Segment Game

Problem Description
Lillian is a clever girl so that she has lots of fans and often receives gifts from her fans.

One day Lillian gets some segments from her fans Lawson with lengths of 1,2,3... and she intends to display them by adding them to a number line.At the i-th add operation,she will put the segment with length of i on the number line.Every time she put the segment on the line,she will count how many entire segments on that segment.During the operation ,she may delete some segments on the line.(Segments are mutually independent)
 

Input
There are multiple test cases.

The first line of each case contains a integer n — the number of operations(1<=n<= 2105, n<= 7105)

Next n lines contain the descriptions of the operatons,one operation per line.Each operation contains two integers a , b. 

if a is 0,it means add operation that Lilian put a segment on the position b(|b|< 109) of the line.
(For the i-th add operation,she will put the segment on [b,b+i] of the line, with length of i.)

if a is 1,it means delete operation that Lilian will delete the segment which was added at the b-th add operation.
 

Output
For i-th case,the first line output the test case number.

Then for each add operation,ouput how many entire segments on the segment which Lillian newly adds.
 

Sample Input
 
   
3 0 0 0 3 0 1 5 0 1 0 0 1 1 0 1 0 0
 

Sample Output
 
   
Case #1: 0 0 0 Case #2: 0 1 0 2
题意:给你n个操作,每次添加线段或者删除第i个添加操作中添加的线段,问你每次添加操作中,所添加的线段会覆盖多少条完整的线段。
这题思路挺简单,用树状数组或者线段树进行单点更新,然后求得区间内包括的线段就可以,但有两个注意点:
1.每次添加线段都比之前的所有线段长,所以求区间内线段数的时候不用考虑横穿整个区间。仅仅需考虑所有在区间内或者部分在区间内。部分在区间外的线段。

2.这里的删减操作是删除第i个添加操作的线段,添加操作也是添加一条长为当前第i个添加操作的长度是i。注意是添加操作,不是总的操作!

这里wa了10多次。。。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define maxn 200050
struct node{
	int l,r,f;
}a[maxn];
int b1[2*maxn],b2[2*maxn],pos[2*maxn],caozuo[2*maxn];
int lowbit(int x){
	return x&(-x);
}

void update1(int pos,int num){
	while(pos<=2*maxn){
		b1[pos]+=num;pos+=lowbit(pos);
	}
}

int getsum1(int pos){
	int num=0;
	while(pos>0){
		num+=b1[pos];pos-=lowbit(pos);
	}
	return num;
}

void update2(int pos,int num){
	while(pos<=2*maxn){
		b2[pos]+=num;pos+=lowbit(pos);
	}
}

int getsum2(int pos){
	int num=0;
	while(pos>0){
		num+=b2[pos];pos-=lowbit(pos);
	}
	return num;
}

int main()
{
	int n,m,i,j,d,tot,s1,s2,t1,t2,num1=0,caozuo1;
	while(scanf("%d",&n)!=EOF)
	{
		tot=0;caozuo1=0;
		//memset(caozuo,0,sizeof(caozuo));
		//memset(pos,0,sizeof(pos));
		for(i=1;i<=n;i++){
			scanf("%d%d",&a[i].f,&d);
			if(a[i].f==0){
				caozuo1++;caozuo[caozuo1]=i;
				//caozuo++;a[i].idx=caozuo;
				a[i].l=d;a[i].r=d+caozuo1;
				tot++;pos[tot]=a[i].l;
				tot++;pos[tot]=a[i].r;
			}
			else if(a[i].f==1){
				d=caozuo[d];
				a[i].l=a[d].l;a[i].r=a[d].r;
			}
		}
		num1++;
		printf("Case #%d:\n",num1);
		memset(b1,0,sizeof(b1));
		memset(b2,0,sizeof(b2));
		sort(pos+1,pos+1+tot);
		m=1;
		for(i=2;i<=tot;i++){
			if(pos[i]!=pos[m]){
				m++;pos[m]=pos[i];
			}
		}
		for(i=1;i<=n;i++){
			if(a[i].f==0){
				t1=lower_bound(pos+1,pos+m+1,a[i].l)-pos;
				t2=lower_bound(pos+1,pos+m+1,a[i].r)-pos;
				s1=getsum1(t2)-getsum1(t1-1);
				s2=getsum2(t2);
				printf("%d\n",s1-s2);
				update1(t1,1);
				update2(t1,1);
				update2(t2,-1);
			}
			else if(a[i].f==1){
				t1=lower_bound(pos+1,pos+m+1,a[i].l)-pos;
				t2=lower_bound(pos+1,pos+m+1,a[i].r)-pos;
				update1(t1,-1);
				update2(t1,-1);
				update2(t2,1);
			}
		}	
	}
	return 0;
}
/*
5
0 3
0 4
0 1
0 4
0 -1
*/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值