Prime Path(bfs)

A - Prime Path(11.1.1)
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0


#include<iostream>
using namespace std;


typedef class
{
public:
int prime;
int step;
}number;


bool JudgePrime(int digit)
{
if(digit==2 || digit==3)
return true;
else if(digit<=1 || digit%2==0)
return false;
else if(digit>3)
{
for(int i=3;i*i<=digit;i+=2)
if(digit%i==0)
return false;
return true;
}
}


int a,b;
bool vist[15000];
number queue[15000];


void BFS(void)
{
int i;  //temporary
int head,tail;
queue[head=tail=0].prime=a;
queue[tail++].step=0;
vist[a]=true;


while(head<tail)
{
number x=queue[head++];
if(x.prime==b)
{
cout<<x.step<<endl;
return;
}


int unit=x.prime%10;       //获取x的个位
int deca=(x.prime/10)%10;  //获取x的十位


for(i=1;i<=9;i+=2)     //枚举x的个位,保证四位数为奇数(偶数必不是素数)
{
int y=(x.prime/10)*10+i;
if(y!=x.prime && !vist[y] && JudgePrime(y))
{
vist[y]=true;
queue[tail].prime=y;
queue[tail++].step=x.step+1;
}
}
for(i=0;i<=9;i++)     //枚举x的十位
{
int y=(x.prime/100)*100+i*10+unit;
if(y!=x.prime && !vist[y] && JudgePrime(y))
{
vist[y]=true;
queue[tail].prime=y;
queue[tail++].step=x.step+1;
}
}
for(i=0;i<=9;i++)     //枚举x的百位
{
int y=(x.prime/1000)*1000+i*100+deca*10+unit;
if(y!=x.prime && !vist[y] && JudgePrime(y))
{
vist[y]=true;
queue[tail].prime=y;
queue[tail++].step=x.step+1;
}
}
for(i=1;i<=9;i++)     //枚举x的千位,保证四位数,千位最少为1
{
int y=x.prime%1000+i*1000;
if(y!=x.prime && !vist[y] && JudgePrime(y))
{
vist[y]=true;
queue[tail].prime=y;
queue[tail++].step=x.step+1;
}
}


}


cout<<"Impossible"<<endl;
return;
}


int main(void)
{
int test;
cin>>test;
while(test--)
{
cin>>a>>b;
memset(vist,false,sizeof(vist));
BFS();
}
return 0;
}



先说一下bfs吧,,就是广搜,宽搜,

比如这一题,首先拿第一格例子,,1033 8179;

设一个数初始1033,当等于8179时,说明能结束了;

首先搜1033中只更改一个数的,,,并记下此时到达该数的步数

是(排除1033本身)

1031  1
1039 1
1013 1
1063 1
1093 1
1433 1
1733 1
1933 1



第二步,再分别对这8个数进行广搜   (再次搜索时排除这9个数),这时这些数搜到的数的步数都为2;

第三步,重复第二步

。。。。。

此时,谁先到达8197,他所代表的步数即为最小步数,输出,结束。

转载于:https://www.cnblogs.com/lengxia/p/4387806.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值