POJ 3126 Prime Path bfs

26 篇文章 0 订阅

http://poj.org/problem?id=3126

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033
1733
3733
3739
3779
8779
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

题目大意:给出两个素数n和m,你只能把一个素数转换成另一个素数且两个数只有一位不相同。 问从n转换到m所需要的最少步数。

思路:筛出1000-10000内的素数,bfs即可。修改操作可枚举当前素数的每一位,即4*10种情况。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

const int maxn=1e5+5;

int prime[maxn];
int vis[maxn];
int cnt[maxn];
int num[4];
int n,m,t,k;

void oula()
{
    for(int i=2;i<=10000;i++)
    {
        if(!vis[i])
            prime[++k]=i;
        for(int j=1;j<=k&&prime[j]*i<=10000;j++)
        {
            vis[prime[j]*i]=1;
            if(i%prime[j]==0)
                break;
        }
    }
}

void bfs()
{
    memset(cnt,0,sizeof(cnt));
    queue<int> q;
    q.push(n);
    int cur,nxt,tmp;
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        num[0]=cur/1000;
        num[1]=cur%1000/100;
        num[2]=cur%100/10;
        num[3]=cur%10;
        for(int i=0;i<=3;i++)
        {
            tmp=num[i];
            for(int j=0;j<=9;j++)
            {
                if(j==tmp)
                    continue;
                num[i]=j;
                nxt=num[0]*1000+num[1]*100+num[2]*10+num[3];
                if(!vis[nxt]&&cnt[nxt]==0&&nxt>1000)
                {
                    cnt[nxt]=cnt[cur]+1;
                    if(nxt==m)
                    {
                        printf("%d\n",cnt[nxt]);
                        return ;
                    }
                    q.push(nxt);
                }
            }
            num[i]=tmp;
        }
    }
}

int main()
{
    scanf("%d",&t);
    oula();
    while(t--)
    {
        scanf("%d %d",&n,&m);
        if(n==m)
            printf("0\n");
        else
            bfs();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值