poj 2406 Power Strings

kmp优化过的求next的方法不能直接用

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 28897 Accepted: 12062

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

/*=============================================================================
#     FileName: 2406.cpp
#         Desc: poj 2406
#       Author: zhuting
#        Email: cnjs.zhuting@gmail.com
#     HomePage: my.oschina.net/locusxt
#      Version: 0.0.1
#    CreatTime: 2013-12-21 14:45:54
#   LastChange: 2013-12-21 14:45:54
#      History:
=============================================================================*/
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>

#define maxn 1000010

char str[maxn];

/*直接用优化过的求next方法没法解这道题*/
int* get_next(char* a)
{
	int len = strlen(a);
	if (len <= 0) return NULL;
	int j = 0, k = -1;
	int* n = new int[len + 1];/*n[len+1]记录以a[0]开头与a[len-1]结尾的等长相同的字符串的最长长度*/
	n[0] = -1;
	while(j < len)
	{
		if (k >= 0 && a[k] != a[j])
		{
			k = n[k];
		}
		++j;
		++k;
		n[j] = k;
	}
	return n;
}

int main()
{
	while(scanf("%s", str) != EOF)
	{
		if (str[0] == '.') break;
		int len = strlen(str);
		int* tmp = get_next(str);

		int delta = len - tmp[len];
		if (len % delta || str[len - 1] != str[tmp[len] - 1])/*特别注意aaab这种情况*/
			printf("1\n");
		else
			printf("%d\n", len / delta);
		
		/*test*/
		/*
		for (int i = 0; i <= len; ++i)
		{
			printf("%d ", tmp[i]);
		}
		printf("\n");*/
	}

	return 0;
}



转载于:https://my.oschina.net/locusxt/blog/186485

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值