计算几何 --- 哈希优化

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 15581 Accepted: 5900

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

 

【题目来源】
Rocky Mountain 2004

 

【题目大意】

给你一些点的坐标,让你判断这些点可以组成多少个正方形。

 

【题目分析】

这题的时间为3500MS,开始用暴力枚举任意四个点+暴搜做了,果断超时,后来看了别人的解题报告才明白,其实这题不需要枚举任意四个点,枚举任意两个点就行了,另外两个点可以通过公式算出来,公式推导也比较简单,自己画图,将每个顶点都作一条平行于x轴、y轴的直线,关系一眼就看出来了,另外还需要用哈希表来优化。

 

#include<cstdio>
#include<cstring>
#include<iostream>
#define MAX 5000
using namespace std;
int x1,y1,x2,y2,x3,y3,x4,y4,sum,n,a,b;
bool hash[MAX][MAX];
int sx[MAX],sy[MAX];

int find(int x,int y)
{
    if(hash[x+2500][y+2500])
        return 1;
    else
        return 0;
}

int main()
{
    while(scanf("%d",&n),n)
    {
        sum=0;
        memset(hash,0,sizeof(hash));
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&a,&b);
            sx[i]=a;
            sy[i]=b;
            hash[a+2500][b+2500]=1;
        }
        for(int i=0;i<n;i++)
        {
            x1=sx[i];
            y1=sy[i];
            for(int j=0;j<i;j++)
            {
                x2=sx[j];
                y2=sy[j];
                x3=x1+(y1-y2);
                y3=y1-(x1-x2);
                x4=x2+(y1-y2);
                y4=y2-(x1-x2);
                if(find(x3,y3)&&find(x4,y4))
                    sum++;
                x3=x1-(y1-y2);
                y3=y1+(x1-x2);
                x4=x2-(y1-y2);
                y4=y2+(x1-x2);
                if(find(x3,y3)&&find(x4,y4))
                    sum++;
            }
        }
        printf("%d\n",sum/4);
    }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

转载于:https://www.cnblogs.com/crazyacking/p/3757756.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值