2015南阳CCPC C - The Battle of Chibi DP

C - The Battle of Chibi

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

Description



Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao's army. But all generals and soldiers of Cao Cao were loyal, it's impossible to convince any of them to betray Cao Cao.

So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering.

Yu Zhou discussed with Gai Huang and worked out N information to be leaked, in happening order. Each of the information was estimated to has ai value in Cao Cao's opinion.

Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact M information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the N information and just select M of them. Find out how many ways Gai Huang could do this.

Input

The first line of the input gives the number of test cases, T(1≤100). T test cases follow.

Each test case begins with two numbers N(1≤N≤103) and M(1≤M≤N), indicating the number of information and number of information Gai Huang will select. Then N numbers in a line, the ith number ai(1≤ai≤109) indicates the value in Cao Cao's opinion of the ith information in happening order.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the ways Gai Huang can select the information.

The result is too large, and you need to output the result mod by 1000000007(109+7).

Sample Input

2
3 2
1 2 3
3 2
3 2 1

Sample Output

Case #1: 3
Case #2: 0

HINT

 

题意

给你n个数,求长度为m的上升子序列有多少个

题解:

n^3方法:dp[i][j]表示结尾为i,长度为j的有多少个,转移是O(n)的、

那么我们用树状数组优化转移过程,优化到n^2logn就可以AC了

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <string>
#include <stack>
#include <bitset>
#define INF 1000000005
#define eps 1e-12
#define PI acos(-1.0)
#define LL long long

using namespace std;

const int maxn = 1005;
const int mod = 1000000007;
inline long long read()
{
    long long x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int a[maxn], b[maxn], c[maxn][maxn], n, m, dp[maxn][maxn];

inline void Init()
{
    for (int i = 1; i <= n; i++)
    {
        a[i] = b[i] = 0;
        for (int j = 1; j <= n; j++)
            dp[i][j] = c[i][j] = 0;
    }
    return;
}

inline int Lowbit(int x)
{
    return x & (- x);
}

inline void Update(int l, int pos, int key)
{
    while(pos <= n)
    {
        c[l][pos] = (c[l][pos] + key);
        while(c[l][pos]>=mod)
            c[l][pos] -= mod;
        pos = pos + Lowbit(pos);
    }
    return;
}

inline int Sum(int l, int pos)
{
    int temp = 0;
    while(pos)
    {
        temp = (temp + c[l][pos]);
        while(temp >= mod)temp -= mod;
        pos = pos - Lowbit(pos);
    }
    return temp;
}

int main()
{
    int T, cas = 0;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n, &m);
        Init();
        for (int i = 1; i <= n; i++)
        {
            a[i]=read();
            //scanf("%d", &a[i]);
            b[i] = a[i];
        }
        sort(b + 1, b + 1 + n);
        for (int i = 1; i <= n; i++)
            a[i] = lower_bound(b + 1, b + 1 + n, a[i]) - b;
    //    cout << -1 << endl;
        for (int i = 1; i <= n; i++)
        {
           // cout << a[i] << endl;
            dp[i][1] = 1;
            for (int j = 2; j <= i; j++)
                dp[i][j] = Sum(j - 1, a[i] - 1);
            for (int j = 1; j <= i; j++)
                Update(j, a[i], dp[i][j]);
        }
        long long ans = 0;
        for (int i = 1; i <= n; i++)
            {
                ans = (ans + dp[i][m]);
                while(ans>=mod)
                    ans-=mod;// % mod;
                //cout << dp[i][m] << endl;
            }
        printf("Case #%d: %lld\n", ++cas, ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值