Matrix

 Matrix
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1
/*
题意:给你一个n*n的矩阵,初始的值都是0,每个元素只能是0或者1,现在有两种操作:
     C x1 y1 x2 y2 以(x1,y2) 为左下角顶点,(x2,y2)为右上角顶点的矩形内的(包括边界)元素进行异或
     Q x y (1 <= x, y <= n) 询问(x,y)位置的元素是1还是0

初步思路:二维树状数组,每次异或操作元素就+1,查询的是时候只需要看是奇数还是偶数

#错误:不是正经的树状数组,正经的树状数组是向外更新,向内求和,但是这个题不能这么搞,向外更新的话有的地方
    更新不到,所以只能逆向树状数组

#上面的错误不是错误:忘了初始化了
*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#define N 1005
#define lowbit(x) x&(-x)
using namespace std;
int t,n,q;
char str[2];
int X1,X2,Y1,Y2;
int c[N][N];
int sum(int x,int y){
    int res=0;
    for(int i=x;i>0;i-=lowbit(i)){
        for(int j=y;j>0;j-=lowbit(j)){
            res+=c[i][j];
        }
    }
    return res;
}
void add(int x,int y,int val){
    for(int i=x;i<N;i+=lowbit(i)){
        for(int j=y;j<N;j+=lowbit(j)){
            c[i][j]+=val;
        }
    }
}
void init(){
    memset(c,0,sizeof c);
}
int main(){
    // freopen("in.txt","r",stdin);
    scanf("%d",&t);
    while(t--){
        init();
        scanf("%d%d",&n,&q);
        for(int i=0;i<q;i++){
            scanf("%s",str);
            if(str[0]=='C'){
                scanf("%d%d%d%d",&X1,&Y1,&X2,&Y2);
                add(X1,Y1,1);
                add(X2+1,Y1,-1);
                add(X1,Y2+1,-1);
                add(X2+1,Y2+1,1);
            }else{
                scanf("%d%d",&X1,&Y1);
                int res=sum(X1,Y1);
                printf("%d\n",res%2);
            }
        }
        if(t>0){
            printf("\n");
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wuwangchuxin0924/p/6568304.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值