POJ - 2155 Matrix (二维树状数组变形 思维)

题目链接:

http://poj.org/problem?id=2155

题目:

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题目大意:

有一个N*N的矩阵,元素值只可能是0或1。现在有两种操作: 1.C x1 y1 x2 y2:将矩形(x1,y1,x2,y2)的元素全部取反。 2.Q x y:查询(x,y)处的值。 矩阵最是1000*1000,最多有50000次操作。

题目分析:

哈,大家一眼看上去是不是就想到了要用二维线段树或者树状数组,但是呢?如果最暴力来写的话,想一下就觉得会T的。那我们应该怎么办呢?

先不着急,先复习以下树状数组的知识。x不停地 += lowbit(x),就能遍历所有包含x这个点的区间。x 不停地  -= lowbit(x),就能遍历所有在x之前的区间。

下面,我们在思考一个东西。如果要翻转[x,y]之间的所有点,是不是就相当于翻转[1,x-1]和[x,y]这两个区间呢?如果我们用C数组记录1~区间尾的修改次数。然后推广到二维就有:[a,b] -> [c,d]之间的所有点进行翻转,相当于对[1,1] -> [a-1,d]之间的所有点进行翻转,再对[1,1] -> [c,b-1]之间的所有点进行翻转,再对[1,1] -> [a-1,b-1]之间的所有点进行翻转,再对[1,1] -> [c,d]之间的所有点进行翻转更新的时候,所有在x之前的线段都要更新。查询的时候,x的总的修改次数相当于包含x的区间修改次数的和。

再结合刚刚对树状数组的分析,就可以开心的写程序啦~~(其实写法也就相当于交换一下更新和查询

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;
const int MAXN = 1010;
int C[MAXN][MAXN];

int Lowbit(int x) {
    return x & (-x);
}

//以下两个函数不同于一般的树状数组
void Update(int x, int y) {
    for (int i = x; i > 0; i -= Lowbit(i))
        for (int j = y; j > 0; j -= Lowbit(j))
            C[i][j] ^= 1;
}

int GetSum(int x, int y, int n) {
    int sum = 0;
    for (int i = x; i <= n; i += Lowbit(i))
        for (int j = y; j <= n; j += Lowbit(j))
            sum += C[i][j];
    return sum % 2;
}

int main() {
    int T;
    scanf("%d", &T);
    int n, m;
    while (T--) {
        scanf("%d %d", &n, &m);
        memset(C, 0, sizeof(C));
        char com;
        int a, b, c, d;
        while (m--) {
            scanf(" %c %d %d", &com, &a, &b);
            if (com == 'C') {
                scanf("%d %d", &c, &d);
                Update(c, b - 1);
                Update(a - 1, d);
                Update(a - 1, b - 1);
                Update(c, d);
            } else
                printf(GetSum(a, b, n) ? "1\n" : "0\n");
        }
        putchar('\n');
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值