hdu3293(pell方程+快速幂)

裸的pell方程。 然后加个快速幂.

No more tricks, Mr Nanguo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 320    Accepted Submission(s): 207


Problem Description
Now Sailormoon girls want to tell you a ancient idiom story named “be there just to make up the number”. The story can be described by the following words.
In the period of the Warring States (475-221 BC), there was a state called Qi. The king of Qi was so fond of the yu, a wind instrument, that he had a band of many musicians play for him every afternoon. The number of musicians is just a square number.Beacuse a square formation is very good-looking.Each row and each column have X musicians.
The king was most satisfied with the band and the harmonies they performed. Little did the king know that a member of the band, Nan Guo, was not even a musician. In fact, Nan Guo knew nothing about the yu. But he somehow managed to pass himself off as a yu player by sitting right at the back, pretending to play the instrument. The king was none the wiser. But Nan Guo's charade came to an end when the king's son succeeded him. The new king, unlike his father, he decided to divide the musicians of band into some equal small parts. He also wants the number of each part is square number. Of course, Nan Guo soon realized his foolish would expose, and he found himself without a band to hide in anymore.So he run away soon.
After he leave,the number of band is Satisfactory. Because the number of band now would be divided into some equal parts,and the number of each part is also a square number.Each row and each column all have Y musicians.
 

 

Input
There are multiple test cases. Each case contains a positive integer N ( 2 <= N < 29). It means the band was divided into N equal parts. The folloing number is also a positive integer K ( K < 10^9).
 

 

Output
There may have many positive integers X,Y can meet such conditions.But you should calculate the Kth smaller answer of X. The Kth smaller answer means there are K – 1 answers are smaller than them. Beacuse the answer may be very large.So print the value of X % 8191.If there is no answers can meet such conditions,print “No answers can meet such conditions”.
 

 

Sample Input
2 999888 3 1000001 4 8373
 

 

Sample Output
7181 600 No answers can meet such conditions

 

//
//  main.cpp
//  hdu3292
//
//  Created by 陈加寿 on 15/12/1.
//  Copyright (c) 2015年 陈加寿. All rights reserved.
//

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <stdio.h>
#include <string>
#include <math.h>
using namespace std;

#define MOD 8191

void matrix_mul(long long s[4][4],long long t[4][4])
{
    long long tmp[4][4];
    memset(tmp,0,sizeof(tmp));
    for(int i=0;i<2;i++)
        for(int j=0;j<2;j++)
            for(int k=0;k<2;k++)
                tmp[i][j]=(tmp[i][j]+s[i][k]*t[k][j])%MOD;
    for(int i=0;i<2;i++)
        for(int j=0;j<2;j++)
            s[i][j]=tmp[i][j];
}

int main(int argc, const char * argv[]) {
    long long n,k;
    while(cin>>n>>k)
    {
        long long x=sqrt( (double)n );
        if(x*x==n)
        {
            printf("No answers can meet such conditions\n");
            continue;
        }
        //然后开始寻找第一个解
        long long x0,y0;
        for(long long i=1;;i++)
        {
            x=sqrt((double)(i*i*n+1));
            if(x*x==i*i*n+1)
            {
                x0=x;
                y0=i;
                break;
            }
        }
        long long mat[4][4],ans[4][4];
        mat[0][0]=x0; mat[0][1]=y0;
        mat[1][0]=n*y0; mat[1][1]=x0;
        memset(ans,0,sizeof(ans));
        ans[0][0]=1; ans[1][1]=1;
        k-=1;
        while(k)
        {
            if(k&1) matrix_mul(ans,mat);
            k>>=1;
            matrix_mul(mat,mat);
        }
        long long ans1;
        ans1 = (x0*ans[0][0]+y0*ans[1][0])%MOD;
        cout<<ans1<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值