[657] The die is cast UVA



Description

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.  
Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.  

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.  

We make the following assumptions about the input images. The images contain only three different pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.  

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence a1, a2, ..., ak in S such that a = a1 and b = ak , and a i  and a i+1are connected for 1 <= i < k.  

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy 5 <= w, h <= 50.  

The following h lines contain w characters each. The characters can be: "." for a background pixel, "*" for a pixel of a die, and "X" for a pixel of a die's dot.  

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.  

The input is terminated by a picture starting with w = h = 0, which should not be processed.  

Output

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.  

Print a blank line after each test case.

Sample Input

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output

Throw 1
1 2 2 4
 
      
本题主要运用了BFS和DFS的思想,应注意以下几点:
(一)输入行和列时应弄清楚先输列数再输行数
(二)答案应从小到大排序
(三)输出时应多输一行空行
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
char ma[60][60];//记录地图
int vis[60][60];//标记是否访问
int an[120];//记录最终答案
struct node
{
    int x,y;
} q[3600],f,t;
int mv[4][2]= {{1,0},{0,1},{0,-1},{-1,0}};//方向
int num=0;//记录每组‘*’中'X'的个数;
int gs=0;//记录‘*’堆的组数
int n,m;
void qsort(int *a,int star,int fin)//快排
{
    int key=a[star],i=star,j=fin;
    if(star>fin)
       return;
    while(i<j)
    {
        while(i<j&&a[j]>=key) j--;
          a[i]=a[j];
          while(i<j&&a[i]<=key) i++;
          a[j]=a[i];
    }
    a[i]=key;
    qsort(a,star,i-1);
    qsort(a,i+1,fin);
}
void dfs(int x,int y)
{
    int i;
    struct node f1;
    vis[x][y]=1;
    for(i=0;i<4;i++)
    {
        f1.x=x+mv[i][0];
        f1.y=y+mv[i][1];
        if(f1.x>=0&&f1.x<n&&f1.y>=0&&f1.y<m&&!vis[f1.x][f1.y]&&ma[f1.x][f1.y]=='X')
        {
            dfs(f1.x,f1.y);
        }
    }
}
void bfs(int x,int y)
{
    f.x=x;
    f.y=y;
    int jin=0,chu=0;
    q[jin++]=f;
    while(chu<jin)
    {
        t=q[chu++];
        if(ma[t.x][t.y]=='X'&&!vis[t.x][t.y])//如果某个X未被访问过
        {
            dfs(t.x,t.y);
            num++;//每调用一次dfs,就是发现了一个或是一群X  
        }
        for(int i=0; i<4; i++)
        {
            f.x=t.x+mv[i][0];
            f.y=t.y+mv[i][1];
            if(f.x>=0&&f.x<n&&f.y>=0&&f.y<m&&!vis[f.x][f.y]&&ma[f.x][f.y]!='.')//在*群里搜索,找X
            {
                if(ma[f.x][f.y]!='X')//是X的话就不标记,X在dfs标记  
                    vis[f.x][f.y]=1;
                q[jin++]=f;
            }
        }
    }
    if(num!=0)//如果num是0的话,说明没发现*群里有X,就不统计
    {
        an[gs++]=num;
        num=0;
    }
}
int main()
{
    int i,j;
    int time=0;
    while(~scanf("%d %d",&m,&n)&&n!=0&&m!=0)
    {
        time++;
        getchar();
        memset(vis,0,sizeof(vis));
        for(i=0; i<n; i++)
            scanf("%s",ma[i]);
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                if((ma[i][j]=='*'||ma[i][j]=='X')&&!vis[i][j])//循环访问地图,合适的进行bfs搜索  
                {
                    bfs(i,j);
                }
            }
        }
        qsort(an,0,gs-1);
        printf("Throw %d\n",time);
        for(i=0;i<gs;i++)
        {
            if(i!=gs-1)
                printf("%d ",an[i]);
            else
                printf("%d\n\n",an[i]);
        }
        gs=0;
    }
    return 0;
}
 
     

转载于:https://www.cnblogs.com/jiangyongy/p/3971668.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值