HackerRank,一行代码解决输出问题

Task 
Read an integer N.

Without using any string methods, try to print the following:

1,2,3.....N

Note that "....." represents the values in between.

Input Format 
The first line contains an integer N.

Output Format 
Output the answer as explained in the task.

Sample Input

3

Sample Output

123

Pro Tip 
You can use the print function inside a map(). Can you do a 1 line code to solve the problem above?

from __future__ import print_function
map(lambda x: print(x,end=''), range(1,input()+1))


转载于:https://my.oschina.net/zpengseu/blog/539008

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值