POJ1740|A NEW STONE GAME|博弈论

Description
Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.
Input
The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.
Output
For each test case, if Alice win the game,output 1,otherwise output 0.
Sample Input
3
2 1 3
2
1 1
0
Sample Output
1
0

分析:大神说是构造博弈Orz……其实看大神题解之后觉得不难。

从简单开始,首先,一堆的话先手必胜。

如果有两堆,则只有两堆相同的时候先手会输。若两堆不同,先手可以造成两堆相同的局面从而不输。

如果有三堆,先手可以拿走一堆并制造两堆相同的情况。

我们发现,将n堆石子排序,如果石子数量对称,即每种数量的石子有偶数堆,则先手必输。因为先手并不能取光所有的,而后手只要模仿先手的行为就能一直有石子可取。

继续推理,我们会发现只有这种情况先手会输。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,a[11];
int main()
{
    while (scanf("%d",&n))
    {
        if (n==0) return 0;
        for (int i=1; i<=n; i++) scanf("%d",&a[i]);
        if (n%2==1) printf("1\n");
        else 
        {
             int i;
             sort(a+1,a+n+1);
             for (i=1; i<=n;i +=2)
                 if (a[i]!=a[i+1]) { printf("1\n"); break; }
             if (i>n) printf("0\n");
        }
  }
}

 

转载于:https://www.cnblogs.com/Shymuel/p/4649417.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值