[USACO09FEB]改造路Revamping Trails

题目描述

Farmer John dutifully checks on the cows every day. He traverses some of the M (1 <= M <= 50,000) trails conveniently numbered 1..M from pasture 1 all the way out to pasture N (a journey which is always possible for trail maps given in the test data). The N (1 <= N <= 10,000) pastures conveniently numbered 1..N on Farmer John's farm are currently connected by bidirectional dirt trails. Each trail i connects pastures P1_i and P2_i (1 <= P1_i <= N; 1 <= P2_i <= N) and requires T_i (1 <= T_i <= 1,000,000) units of time to traverse.

He wants to revamp some of the trails on his farm to save time on his long journey. Specifically, he will choose K (1 <= K <= 20) trails to turn into highways, which will effectively reduce the trail's traversal time to 0. Help FJ decide which trails to revamp to minimize the resulting time of getting from pasture 1 to N.

TIME LIMIT: 2 seconds

约翰一共有N)个牧场.由M条布满尘埃的小径连接.小径可 以双向通行.每天早上约翰从牧场1出发到牧场N去给奶牛检查身体.

通过每条小径都需要消耗一定的时间.约翰打算升级其中K条小径,使之成为高 速公路.在高速公路上的通行几乎是瞬间完成的,所以高速公路的通行时间为0.

请帮助约翰决定对哪些小径进行升级,使他每天早上到牧场W花的时间最少.输出这个最少 的时间.

输入输出格式

输入格式:

 

  • Line 1: Three space-separated integers: N, M, and K

  • Lines 2..M+1: Line i+1 describes trail i with three space-separated integers: P1_i, P2_i, and T_i

 

输出格式:

 

  • Line 1: The length of the shortest path after revamping no more than K edges

 

输入输出样例

输入样例#1:
4 4 1 
1 2 10 
2 4 10 
1 3 1 
3 4 100 
输出样例#1:
1 

说明

K is 1; revamp trail 3->4 to take time 0 instead of 100. The new shortest path is 1->3->4, total traversal time now 1.

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int n,m,k;
struct node
{
    int next,to,dis;
}edge[100005];
int head[10005],size;
struct Node
{
    int to,dis,sum;
    friend bool operator<(Node a,Node b){return a.dis>b.dis;}
};
void putin(int from,int to,int dis)
{
    size++;
    edge[size].next=head[from];
    edge[size].to=to;
    edge[size].dis=dis;
    head[from]=size;
}
void in(int from,int to,int dis)
{
    putin(from,to,dis);
    putin(to,from,dis);
}
int dist[10005][25],vis[10005][25];
void dijsktra(int r)
{
    int i;
    priority_queue<Node>mem;
    memset(dist,127/3,sizeof(dist));
    dist[r][0]=0;
    mem.push((Node){r,0,0});
    while(!mem.empty())
    {
        Node x=mem.top();mem.pop();
        if(vis[x.to][x.sum])continue;
        vis[x.to][x.sum]=1;
        for(i=head[x.to];i!=-1;i=edge[i].next)
        {
            int y=edge[i].to;
            if(dist[y][x.sum+1]>dist[x.to][x.sum]&&x.sum+1<=k)
            {
                dist[y][x.sum+1]=dist[x.to][x.sum];
                mem.push((Node){y,dist[y][x.sum+1],x.sum+1});
            }
            if(dist[y][x.sum]>dist[x.to][x.sum]+edge[i].dis)
            {
                dist[y][x.sum]=dist[x.to][x.sum]+edge[i].dis;
                mem.push((Node){y,dist[y][x.sum],x.sum});
            }
        }
    }
}
int main()
{
    int i,j;
    memset(head,-1,sizeof(head));
    scanf("%d%d%d",&n,&m,&k);
    for(i=1;i<=m;i++)
    {
        int from,to,dis;
        scanf("%d%d%d",&from,&to,&dis);
        in(from,to,dis);
    }
    dijsktra(1);
    cout<<dist[n][k]<<endl;
    return 0;
}

 

转载于:https://www.cnblogs.com/huangdalaofighting/p/7152522.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值