hdu 4950 Monster(数学题,多校8)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4950


Monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 220    Accepted Submission(s): 92


Problem Description
Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.

Monster initially has h HP. And it will die if HP is less than 1.

Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.

After k consecutive round's attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.

Output "YES" if Teacher Mai can kill this monster, else output "NO".
 
Input
There are multiple test cases, terminated by a line "0 0 0 0".

For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).
 
Output
For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".
 
Sample Input
 
   
5 3 2 2 0 0 0 0
 
Sample Output
 
   
Case #1: NO
 
Source

题意: 给出怪兽的血量h,玩家每回合造成的伤害a,每一回合结束后怪兽会回血量b,玩家在连续攻击k回合后须歇息一次(也能够在K回合之前的随意回合歇息)。推断玩家是否能杀死怪兽!



思路: 贪心。必定是打了K回合后再歇息!详细见代码解析;




代码例如以下:

#include<cstdio>
typedef __int64 LL;
int main()
{
    LL h,a,b,k;
    LL cas = 0;
    while(~scanf("%I64d%I64d%I64d%I64d",&h,&a,&b,&k))
    {
        if(h==0 && a==0 && b==0 && k==0)
            break;
        printf("Case #%I64d: ",++cas);
        if(h <= a)//第一回合怪兽就死亡
        {
            printf("YES\n");
            continue;
        }
        if((k-1)*(-a+b)-a+h <= 0)//前K回合怪兽死亡
        {
            printf("YES\n");
            continue;
        }
        if(k*(-a+b)+b < 0)//每K回合后怪兽的血量在降低
        {
            printf("YES\n");
            continue;
        }
        printf("NO\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值