R3
router eigrp 200
 network 200.1.1.0
 network 201.1.13.0 0.0.0.3
 network 201.1.23.0 0.0.0.3
 no auto-summary
interface FastEthernet0/0
 ip address 200.1.1.3 255.255.255.0

interface Serial1/0
 ip address 201.1.13.2 255.255.255.252
 
interface Serial1/1
 ip address 201.1.23.2 255.255.255.252
 

show ip eigrp neighbors
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
2   201.1.23.1              Se1/1             14 00:02:47  399  2394  0  34
1   201.1.13.1              Se1/0             14 00:02:55 1880  5000  0  21
0   200.1.1.2               Fa0/0             14 00:03:06 1768  5000  0  31
R3#show ip eigrp topo
IP-EIGRP Topology Table for AS(200)/ID(201.1.23.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
P 192.1.1.0/24, 1 successors, FD is 2297856
        via 201.1.13.1 (2297856/128256), Serial1/0
P 192.1.2.0/24, 1 successors, FD is 156160
        via 200.1.1.2 (156160/128256), FastEthernet0/0
        via 201.1.23.1 (2297856/128256), Serial1/1
P 201.1.13.0/30, 1 successors, FD is 2169856
        via Connected, Serial1/0
P 200.1.1.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 201.1.23.0/30, 1 successors, FD is 2169856
        via Connected, Serial1/1
r3#show ip route eigrp
D    192.1.1.0/24 [90/2297856] via 201.1.13.1, 00:04:28, Serial1/0
D    192.1.2.0/24 [90/156160] via 200.1.1.2, 00:04:28, FastEthernet0/0
查看topo表的时候我们可以看到,到192.1.2.0/24网段有2条路径.其度量值分别是156160 和 2297856,
后者是前者的10几倍.但在我们查看route 表中时.却只有一条路径.
因为eigrp协议缺省的变化量(variance)值为1.
当我们把variance的值改为15时.表中发生了变化.这样实现了 不等价度量值的负载均衡.
r3(config-router)#variance 15
r3(config-router)#do show ip route eigrp
D    192.1.1.0/24 [90/2297856] via 201.1.13.1, 00:00:48, Serial1/0
D    192.1.2.0/24 [90/2297856] via 201.1.23.1, 00:00:48, Serial1/1
                  [90/156160] via 200.1.1.2, 00:00:48, FastEthernet0/0
? 为什么要改为15了?
意味着针对目标网段,所有具有与最小度量值只比小于15的度量值的路径将选中(对于本例中.2297856/156160<15),
进入路由表.
variance的值是1-128

R2
router eigrp 200
 network 192.1.2.0
 network 200.1.1.0
 network 201.1.23.0 0.0.0.3
 no auto-summary
interface Loopback2
 ip address 192.1.2.2 255.255.255.0
interface FastEthernet0/0
 ip address 200.1.1.2 255.255.255.0
interface Serial1/0
 ip address 201.1.23.1 255.255.255.252
r2#show ip route eig
     201.1.13.0/30 is subnetted, 1 subnets
D       201.1.13.0 [90/2172416] via 200.1.1.3, 00:26:22, FastEthernet0/0
D    192.1.1.0/24 [90/2300416] via 200.1.1.3, 00:26:24, FastEthernet0/0
这时只有一个地址哦@
r2(config)#router eigrp 200
r2(config-router)#variance 15
r2(config-router)#do show ip route ei
     201.1.13.0/30 is subnetted, 1 subnets
D       201.1.13.0 [90/2681856] via 201.1.23.2, 00:00:11, Serial1/0
                   [90/2172416] via 200.1.1.3, 00:00:11, FastEthernet0/0
D    192.1.1.0/24 [90/2809856] via 201.1.23.2, 00:00:11, Serial1/0
                  [90/2300416] via 200.1.1.3, 00:00:11, FastEthernet0/0
 
~~哈哈 当我们再把variance 15时 ,就有两个非等价的负载.
不等价的负载均衡能否实现.除了要设置variane 大于15之外,还要看路由允许的最大数.
当我们把maximum-path 1 是 再看这个route eigrp时~~
缺省的是4.可设置的范围1~6.
r2(config-router)#maximum-paths 1
r2(config-router)#do show ip route ei
     201.1.13.0/30 is subnetted, 1 subnets
D       201.1.13.0 [90/2172416] via 200.1.1.3, 00:00:08, FastEthernet0/0
D    192.1.1.0/24 [90/2300416] via 200.1.1.3, 00:00:09, FastEthernet0/0
r2(config-router)#do show ip protocol
 Maximum path: 1
  Routing for Networks:
    192.1.2.0
    200.1.1.0
    201.1.23.0/30
  Routing Information Sources:
    Gateway         Distance      Last Update
    (this router)         90      00:39:03
    200.1.1.3             90      00:00:33
    201.1.23.2            90      00:00:33
  Distance: internal 90 external 170
 
 
 
R1
router eigrp 200
 network 192.1.1.0
 network 201.1.13.0 0.0.0.3
 no auto-summary
 no eigrp log-neighbor-changes