配置EIGRP等价负载均衡和非等价负…

配置EIGRP等价负载均衡和非等价负载均衡

实验目标:配置R3到192.168.0.0/24网段可以走多条路.

一:预配置:
R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface Loopback2
ip address 10.1.1.1 255.255.255.252
interface Loopback3
ip address 10.1.1.5 255.255.255.252
interface Loopback4
ip address 10.1.1.9 255.255.255.252
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
interface Serial2/1
ip address 192.168.0.1 255.255.255.0

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface Loopback2
ip address 10.1.2.1 255.255.255.252
interface Loopback3
ip address 10.1.2.5 255.255.255.252
interface Loopback4
ip address 10.1.2.9 255.255.255.252
interface Serial2/1
ip address 192.168.0.2 255.255.255.0
interface Serial2/2
ip address 23.0.0.2 255.255.255.0

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Loopback2
ip address 10.1.3.1 255.255.255.252
interface Loopback3
ip address 10.1.3.5 255.255.255.252
interface Loopback4
ip address 10.1.3.9 255.255.255.252
interface FastEthernet0/0
ip address 172.16.0.3 255.255.255.0
interface Serial2/1
ip address 23.0.0.3 255.255.255.0


二:配置过程
1:修改R1,R2,R3之间的链路带宽为64Kbps
R1(config)#int s2/1
R1(config-if)#bandwidth 64
R1(config-if)#int f0/0
R1(config-if)#bandwidth 64

R2(config)#int s2/1
R2(config-if)#bandwidth 64
R2(config-if)#int s2/2
R2(config-if)#bandwidth 64

R3(config)#int s2/1
R3(config-if)#bandwidth 64
R3(config-if)#int f0/0
R3(config-if)#bandwidth 64

2:配置EIGRP
R1(config)#router eigrp 100
R1(config-router)#no au
R1(config-router)#net 10.0.0.0
R1(config-router)#net 172.16.0.0
R1(config-router)#net 192.168.0.0
R1(config-router)#net 1.1.1.1

R2(config)#router eigrp 100
R2(config-router)#no au
R2(config-router)#net 10.0.0.0
R2(config-router)#net 2.2.2.2
R2(config-router)#net 23.0.0.0
R2(config-router)#net 192.168.0.0

R3(config)#router eigrp 100
R3(config-router)#no au
R3(config-router)#net 10.0.0.0
R3(config-router)#net 3.3.3.3
R3(config-router)#net 172.16.0.0
R3(config-router)#net 23.0.0.0


R1#show ip route

     1.0.0.0/24 is subnetted, 1 subnets
      1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
      2.2.2.0 [90/40640000] via 192.168.0.2, 00:01:58, Serial2/1
     3.0.0.0/24 is subnetted, 1 subnets
      3.3.3.0 [90/40130560] via 172.16.0.3, 00:01:58, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
      23.0.0.0 [90/40514560] via 172.16.0.3, 00:01:58, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
      172.16.0.0 is directly connected, FastEthernet0/0
     10.0.0.0/30 is subnetted, 9 subnets
      10.1.3.8 [90/40130560] via 172.16.0.3, 00:01:58, FastEthernet0/0
      10.1.2.8 [90/40640000] via 192.168.0.2, 00:01:58, Serial2/1
      10.1.1.8 is directly connected, Loopback4
      10.1.3.0 [90/40130560] via 172.16.0.3, 00:01:58, FastEthernet0/0
      10.1.2.0 [90/40640000] via 192.168.0.2, 00:01:58, Serial2/1
      10.1.1.0 is directly connected, Loopback2
      10.1.3.4 [90/40130560] via 172.16.0.3, 00:01:58, FastEthernet0/0
      10.1.2.4 [90/40640000] via 192.168.0.2, 00:01:58, Serial2/1
      10.1.1.4 is directly connected, Loopback3
   192.168.0.0/24 is directly connected, Serial2/1

查看EIGRP邻接关系

R1#show ip eigrp nei
IP-EIGRP neighbors for process 100
  Address                 Interface       Hold Uptime   SRTT   RTO Q Seq
                                            (sec)         (ms)       Cnt Num
  192.168.0.2             Se2/1             13 00:46:31   44 2280 0 15
  172.16.0.3              Fa0/0             12 00:46:46 171 2280 0 16

R2#show ip eigrp nei
IP-EIGRP neighbors for process 100
  Address                 Interface       Hold Uptime   SRTT   RTO Q Seq
                                            (sec)         (ms)       Cnt Num
  192.168.0.1             Se2/1             14 00:47:04 124 2280 0 15
  23.0.0.3                Se2/2             13 00:51:32 260 2280 0 17


R3#show ip eigrp nei
IP-EIGRP neighbors for process 100
  Address                 Interface       Hold Uptime   SRTT   RTO Q Seq
                                            (sec)         (ms)       Cnt Num
  172.16.0.1              Fa0/0             14 00:47:35 284 2280 0 16
  23.0.0.2                Se2/1             13 00:51:48 436 2616 0 16


查看R2的路由表
R2#show ip route

     1.0.0.0/24 is subnetted, 1 subnets
      1.1.1.0 [90/40640000] via 192.168.0.1, 00:48:03, Serial2/1
     2.0.0.0/24 is subnetted, 1 subnets
      2.2.2.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
      3.3.3.0 [90/40640000] via 23.0.0.3, 00:48:03, Serial2/2
     23.0.0.0/24 is subnetted, 1 subnets
      23.0.0.0 is directly connected, Serial2/2
     172.16.0.0/24 is subnetted, 1 subnets
      172.16.0.0 [90/40514560] via 23.0.0.3, 00:48:03, Serial2/2
                   [90/40514560] via 192.168.0.1, 00:48:03, Serial2/1
     10.0.0.0/30 is subnetted, 9 subnets
      10.1.3.8 [90/40640000] via 23.0.0.3, 00:48:03, Serial2/2
      10.1.2.8 is directly connected, Loopback4
      10.1.1.8 [90/40640000] via 192.168.0.1, 00:48:03, Serial2/1
      10.1.3.0 [90/40640000] via 23.0.0.3, 00:48:03, Serial2/2
      10.1.2.0 is directly connected, Loopback2
      10.1.1.0 [90/40640000] via 192.168.0.1, 00:48:03, Serial2/1
      10.1.3.4 [90/40640000] via 23.0.0.3, 00:48:03, Serial2/2
      10.1.2.4 is directly connected, Loopback3
      10.1.1.4 [90/40640000] via 192.168.0.1, 00:48:03, Serial2/1
   192.168.0.0/24 is directly connected, Serial2/1

查看R2的eigrp拓扑表

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(10.1.2.9)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.3.8/30, 1 successors, FD is 40640000
        via 23.0.0.3 (40640000/128256), Serial2/2
        via 192.168.0.1 (40642560/40130560), Serial2/1
P 1.1.1.0/24, 1 successors, FD is 40640000
        via 192.168.0.1 (40640000/128256), Serial2/1
        via 23.0.0.3 (40642560/40130560), Serial2/2
P 10.1.2.8/30, 1 successors, FD is 128256
        via Connected, Loopback4
P 10.1.1.8/30, 1 successors, FD is 40640000
        via 192.168.0.1 (40640000/128256), Serial2/1
        via 23.0.0.3 (40642560/40130560), Serial2/2
P 2.2.2.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 3.3.3.0/24, 1 successors, FD is 40640000
        via 23.0.0.3 (40640000/128256), Serial2/2
        via 192.168.0.1 (40642560/40130560), Serial2/1
P 10.1.3.0/30, 1 successors, FD is 40640000
        via 23.0.0.3 (40640000/128256), Serial2/2
         
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

        via 192.168.0.1 (40642560/40130560), Serial2/1
P 10.1.2.0/30, 1 successors, FD is 128256
        via Connected, Loopback2
P 10.1.1.0/30, 1 successors, FD is 40640000
        via 192.168.0.1 (40640000/128256), Serial2/1
        via 23.0.0.3 (40642560/40130560), Serial2/2
P 10.1.3.4/30, 1 successors, FD is 40640000
        via 23.0.0.3 (40640000/128256), Serial2/2
        via 192.168.0.1 (40642560/40130560), Serial2/1
P 10.1.2.4/30, 1 successors, FD is 128256
        via Connected, Loopback3
P 10.1.1.4/30, 1 successors, FD is 40640000
        via 192.168.0.1 (40640000/128256), Serial2/1
        via 23.0.0.3 (40642560/40130560), Serial2/2
P 23.0.0.0/24, 1 successors, FD is 40512000
        via Connected, Serial2/2
P 192.168.0.0/24, 1 successors, FD is 40512000
        via Connected, Serial2/1
P 172.16.0.0/24, 2 successors, FD is 40514560
        via 192.168.0.1 (40514560/40002560), Serial2/1
        via 23.0.0.3 (40514560/40002560), Serial2/2


查看R3的路由表

R3#show ip route
     1.0.0.0/24 is subnetted, 1 subnets
      1.1.1.0 [90/40130560] via 172.16.0.1, 00:50:48, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
      2.2.2.0 [90/40640000] via 23.0.0.2, 00:50:48, Serial2/1
     3.0.0.0/24 is subnetted, 1 subnets
      3.3.3.0 is directly connected, Loopback0
     23.0.0.0/24 is subnetted, 1 subnets
      23.0.0.0 is directly connected, Serial2/1
     172.16.0.0/24 is subnetted, 1 subnets
      172.16.0.0 is directly connected, FastEthernet0/0
     10.0.0.0/30 is subnetted, 9 subnets
      10.1.3.8 is directly connected, Loopback4
      10.1.2.8 [90/40640000] via 23.0.0.2, 00:50:48, Serial2/1
      10.1.1.8 [90/40130560] via 172.16.0.1, 00:50:48, FastEthernet0/0
      10.1.3.0 is directly connected, Loopback2
      10.1.2.0 [90/40640000] via 23.0.0.2, 00:50:48, Serial2/1
      10.1.1.0 [90/40130560] via 172.16.0.1, 00:50:48, FastEthernet0/0
      10.1.3.4 is directly connected, Loopback3
      10.1.2.4 [90/40640000] via 23.0.0.2, 00:50:48, Serial2/1
      10.1.1.4 [90/40130560] via 172.16.0.1, 00:50:48, FastEthernet0/0
   192.168.0.0/24 [90/40514560] via 172.16.0.1, 00:50:50, FastEthernet0/0

查看R3的eigrp拓扑表

R3#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(10.1.3.9)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.3.8/30, 1 successors, FD is 128256
        via Connected, Loopback4
P 1.1.1.0/24, 1 successors, FD is 40130560
        via 172.16.0.1 (40130560/128256), FastEthernet0/0
P 10.1.2.8/30, 1 successors, FD is 40640000
        via 23.0.0.2 (40640000/128256), Serial2/1
P 10.1.1.8/30, 1 successors, FD is 40130560
        via 172.16.0.1 (40130560/128256), FastEthernet0/0
P 2.2.2.0/24, 1 successors, FD is 40640000
        via 23.0.0.2 (40640000/128256), Serial2/1
P 3.3.3.0/24, 1 successors, FD is 128256
        via Connected, Loopback0
P 10.1.3.0/30, 1 successors, FD is 128256
        via Connected, Loopback2
P 10.1.2.0/30, 1 successors, FD is 40640000
        via 23.0.0.2 (40640000/128256), Serial2/1
P 10.1.1.0/30, 1 successors, FD is 40130560
        via 172.16.0.1 (40130560/128256), FastEthernet0/0
         
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.3.4/30, 1 successors, FD is 128256
        via Connected, Loopback3
P 10.1.2.4/30, 1 successors, FD is 40640000
        via 23.0.0.2 (40640000/128256), Serial2/1
P 10.1.1.4/30, 1 successors, FD is 40130560
        via 172.16.0.1 (40130560/128256), FastEthernet0/0
P 23.0.0.0/24, 1 successors, FD is 40512000
        via Connected, Serial2/1
P 192.168.0.0/24, 1 successors, FD is 40514560
        via 172.16.0.1 (40514560/40512000), FastEthernet0/0
        via 23.0.0.2 (41024000/40512000), Serial2/1
P 172.16.0.0/24, 1 successors, FD is 40002560
        via Connected, FastEthernet0/0


配置R3非等价负载均衡
R3(config)#router eigrp 100
R3(config-router)#variance 2


R3#show ip route

     1.0.0.0/24 is subnetted, 1 subnets
      1.1.1.0 [90/40130560] via 172.16.0.1, 00:00:02, FastEthernet0/0
     2.0.0.0/24 is subnetted, 1 subnets
      2.2.2.0 [90/40640000] via 23.0.0.2, 00:00:02, Serial2/1
     3.0.0.0/24 is subnetted, 1 subnets
      3.3.3.0 is directly connected, Loopback0
     23.0.0.0/24 is subnetted, 1 subnets
      23.0.0.0 is directly connected, Serial2/1
     172.16.0.0/24 is subnetted, 1 subnets
      172.16.0.0 is directly connected, FastEthernet0/0
     10.0.0.0/30 is subnetted, 9 subnets
      10.1.3.8 is directly connected, Loopback4
      10.1.2.8 [90/40640000] via 23.0.0.2, 00:00:02, Serial2/1
      10.1.1.8 [90/40130560] via 172.16.0.1, 00:00:03, FastEthernet0/0
      10.1.3.0 is directly connected, Loopback2
      10.1.2.0 [90/40640000] via 23.0.0.2, 00:00:03, Serial2/1
      10.1.1.0 [90/40130560] via 172.16.0.1, 00:00:03, FastEthernet0/0
      10.1.3.4 is directly connected, Loopback3
      10.1.2.4 [90/40640000] via 23.0.0.2, 00:00:03, Serial2/1
      10.1.1.4 [90/40130560] via 172.16.0.1, 00:00:03, FastEthernet0/0
   192.168.0.0/24 [90/40514560] via 172.16.0.1, 00:00:03, FastEthernet0/0
                    [90/41024000] via 23.0.0.2, 00:00:03, Serial2/1

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值