HDU 1213 How Many Tables

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12657    Accepted Submission(s): 6204


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
   
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
 
   
2 4
题意:求你须要的最少数量的桌子。使你全部的朋友能座下来。朋友相互认识的能够座在一起!

思路:用并查集做。把相互认识的朋友放在一个节点,比如:输入1 2。2 3.那么说明1 2 3能够坐在一起,那么我们将2 3 放在f1这个集合中去,每次输入的认识的人的时候,把这2个人放在一个集合
AC代码:
#include<stdio.h>
int sum,f[1005];    //sum为题目所求
int find(int x)     //找根节点
{
    if(f[x]!=x)
        f[x]=find(f[x]);
    return f[x];
}
void  make(int x,int y) 
{
    int f1=find(x);
    int f2=find(y);
    if(f1!=f2)  //2个相互的人放在一个集合中去
    {
        f[f1]=f2;   
        sum--;      //由于有认识的人。所以最少须要的桌子要减去1了
    }
}
int main()
{
    int n,m,i,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        sum=n;      //设開始时全部的人都不认识,所以所需桌子数位n
        for(i=1;i<=n;i++)   //初始化
            f[i]=i;
        for(i=1;i<=m;i++)
        {
            int a,b;
            scanf("%d %d",&a,&b);
            make(a,b);
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值