HDU Problem 4707 Pet【并查集】

Pet

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2497    Accepted Submission(s): 1225

Problem Description
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.
 

 

Input
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.
 

 

Output
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
 

 

Sample Input
1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9
 

 

Sample Output
2
 

 

Source
 

 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5780  5779  5778  5777  5776 
 

 

我一开始看到好多人用容器DFS,但是不幸的是我不会容器【(⊙﹏⊙)b】。反正都是搜索这棵树,我就不妨把0作为树的顶点,问题就变成了大于等于深度d的有几个节点,因为题目上已经说了可以生成一棵树,我就调换了树的元素的位置,把小的元素放在树的上面,方便让0做顶点。
然后遍历所有节点,找到距离小于d的节点有多少,记录下来答案就出来了。

#include <bits\stdc++.h>
#define MAX_N 100005
using namespace std;
const int INF = 1e9;
const double ESP = 1e-5;

int n, k, par[MAX_N];
struct node{
    int from, to;
}uv[MAX_N];
void init() {
    for (int i = 0; i <= n; i++) {
        par[i] = i;
    }
}
bool cmp(node x, node y) {
    return x.from < y.from;
}
bool judge(int x) {
    int cnt = k+1;
    while (cnt--) {
        if (x == 0) return true;
        x = par[x];
    }
    return false;
}
int main() {
    int t, a, b;
        scanf("%d", &t);
    while (t--) {
        scanf("%d%d", &n, &k); init();
        for (int i = 0; i < n-1; i++) {
            scanf("%d%d", &a, &b);
            if (a > b) uv[i].from = b, uv[i].to = a;
            else uv[i].from = a, uv[i].to = b;
        }
        int m = n-1;
        sort(uv, uv + m, cmp);
        for (int i = 0; i < n-1; i++) {
            par[uv[i].to] = uv[i].from;
        }
        int t = 0, ans = 0;
        for (int i = 1; i < n; i++) {
            if (judge(i)) {
                ans++;
            }
        }
        printf("%d\n",n - ans - 1);
    }
    return 0;
}

 


 

转载于:https://www.cnblogs.com/cniwoq/p/6770876.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值