配置交换机主机名称

switch(config)# hostname XXX ;将交换机名称设置为XXX



配置远程登陆
switch(config)# line console 0 ;console登陆配置
switch(config-line)# exec-timeout 5 10 ;设置CONSOLE连线时,如果5分钟10秒用户无操作,即断开连接
switch(config-line)# password xxxxxx;设置CONSOLE口登陆密码为xxxxxx

switch(config-line)# exit ; 返回到全局配置模式
switch(config)# line vty 0 4 ;远程登陆配置,允许从0到4五个用户同时连接。
switch(config-line)# exec-timeout 5 2 ;设置远程登陆时,如果5分钟2两秒用户无操作,即断开连接
switch(config-line)# password xxxxxx ; 设置远程登陆密码为xxxxxx

switch(config-line)# login ;开启远程登陆密码验证功能。如果不开启,远程登陆是直接登陆
的,即使设置了密码也不会验证的,就跟没设置密码一样

配置enable密码

(config)#enable password 123 ;配置明文密码

(config)#enable secret 123 ;配置密文密码

由于密文优先,故两种密码都配置时,系统自动才用密文密码

起TRUNK
interface gigabitEthernet 0/48
switch(config)# interface gigabitEthernet 0/48 ;进入48端口
switch(config-if)# switchport mode trunk ;将该口设置为TRUNK模式

建立VLAN

switch(config)# vlan 3;建立VLAN3

switch(config-vlan)# ip address 192.168.3.254 255.255.255.0;设置vlan管理地址(网关地址)

单个端口放入VLAN 中

switch(config)# interface gigabitEthernet 0/47 ;进入47口
switch(config-if)# switchport ;6系列必须先打此命令
switch(config-if)# switchport mode access ;将该端口工作模式设置为access
switch(config-if)# switchport access vlan 201 ;在access模式下,将该端口放入vlan201中
switch(config-if)# spanning-tree portfast ;设置为快速端口。可不打,默认即为快速
switch(config-if)# no shutdown ;启用端口
switch(config-if)# exit ;退到全局模式
switch(config)# exit ;退到特权模式
switch# write ;保存配置

批量将端口放入VALN中
switch(config)# interface range gigabitEthernet 0/1 - 46 ;进入1-46口。注意空格
其他同单个端口放入vlan中


配置VTP




switch(config)# vtp domain abc ;设置一个VTP区域,名字为abc,与中心交换机的VTP区域名称相同
switch(config)# vtp mode client ;设置楼层交换机VTP模式为CLIENT,中心交换机起VTP SERVER模式,
即可使楼层交换机自动从中心交换机学习VLAN配置


是VLAN中继协议,思科私有协议。把一台交换机配置成VTP Server, 其余交换机配置成VTP Client,这样这些交换机可以自动从SERVER交机上学习到vlan信息


配置IP地址
switch(config)# interface Loopback0 ;

switch(config)# shutdown

switch(config)# vlan 15 ;管理VLAN
switch(config-if)# ip address 192.168.15.51 255.255.255.0;设置 Loopback0地址

switch(config)# interface vlan 1 ;进入默认vlan
switch(config-if)#shutdown;关闭默认管理vlan后,自定义vlan才能生效

二层交换机配置了管理IP地址后,在管理地址的同网段内,就可直接telnet来登录连接到交换机。但若要跨网段去登录连接到另一个网段的二层交换机,就要给他配置网关..

ip default-gateway 192.168.15.254