HDOJ 2114 Calculate S(n)(找周期)

Problem Description
Calculate S(n).

S(n)=1^3+2^3 +3^3 +……+n^3 .

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output
For each case, output the last four dights of S(N) in one line.

Sample Input
1
2

Sample Output
0001
0009

题意是:给一个数n,求S(n)=1^3+2^3 +3^3 +……+n^3 .输出最后4位数字,不足4位的补零输出。

如果没找出周期会超时的。
我找到的是以10000为周期。

import java.util.Scanner;
//10000为周期
public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            int sum =0;
            int t;
            n = n%10000;
            for(int i=1;i<=n;i++){
                sum = ((sum)%10000+(((i)%10000)*((i)%10000))%10000*((i)%10000))%10000;
            }
            if(sum<10){
                System.out.println("000"+sum);
            }else if(sum<100){
                System.out.println("00"+sum);
            }else if(sum<1000){
                System.out.println("0"+sum);
            }else{
                System.out.println(sum);
            }
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值