题解-calculate the angle

Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.<br>We all like toxophily.<br><br>Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?<br><br>Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. <br>
 
Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.<br>Technical Specification<br><br>1. T ≤ 100.<br>2. 0 ≤ x, y, v ≤ 10000. <br>

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.<br>Output "-1", if there's no possible answer.<br><br>Please use radian as unit. <br>
 
Sample Input
 
 
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551

Sample Output
 
 
1.561582 -1 -1

解题思路:

对于自己的物理还是挺有自信的,三个速度公式的变幻当时背的贼溜,式子都推导出来了,期间不明白题中到底要求的是什么角度搜了一下题解,但硬生生错了n遍并改不对;

首先将速度分解,因为其让求的是最小角度,则让目标为抛物线的最高点,列出式子(看代码吧。。敲对一遍不容易),分别为x,y方向上的时间位移公式。因为x方向上是匀速运动,用x表示时间,带入y式中,二次方程直接用求根公式,得到tan(a);

PS:采用物理方法一定一定仔细就够了。。

Bug.1.2.3....n:方程系数没超对

AC.1

#include<bits/stdc++.h>
using namespace std;
const double PI=acos(-1),g=9.8;
int t;
double x,y,v0,deta,ans1,ans2;
void fu()
{
    double a,b,c;
    a=g*x*x;
    b=-2*v0*v0*x;
    c=2*v0*v0*y+g*x*x;
    deta=b*b-4.0*a*c;
    ans1=(-b+sqrt(deta))/(2.0*a);
    ans2=(-b-sqrt(deta))/(2.0*a);
    ans1=atan(ans1);
    ans2=atan(ans2);
//cout<<"a="<<a<<"  b="<<b<<"  c="<<c<<"  ans1="<<ans1<<"  ans2="<<ans2<<endl;

}
void shu()
{
    if(ans1>=0&&ans1<=PI/2.0&&ans2>=0&&ans2<=PI/2.0) {
            printf("%.6lf\n",ans1>ans2?ans2:ans1);
        } else if(ans2>=0&&ans2<=PI/2.0) {
            printf("%.6lf\n",ans2);
        } else if(ans1>=0&&ans1<=PI/2.0) {
            printf("%.6lf\n",ans1);
        } else printf("-1\n");
}
int main()
{
    cin>>t;
    while(t--)
    {
        cin>>x>>y>>v0;
        fu();
        shu();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值