[结题报告]10340 - All in All Time limit: 3.000 seconds

Problem E

All in All

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

参考代码:
这道题给定2个字符串,求前字符串是否在后字符串出现(不要求连续),利用循环可以求出,但是这道题必须注意到的是,2个数组的定义时,务必要足够大,经证明,200000够大,定义过小,会出现Runtime error.
#include"stdio.h"
#include"string.h"
int main()
{
 char s1[200000],s2[200000];
 int i,j;
 while (scanf("%s%s",&s1,&s2)!=EOF)
 {
  for (i=0,j=0;s1[i]!='\0'&&s2[j]!='\0';j++)
  if (s1[i]==s2[j]) ++i;
  if (s1[i]=='\0') printf("Yes\n");
              else printf("No\n");
 }
 return 0;
}

 

 

转载于:https://www.cnblogs.com/sjy123/archive/2013/02/20/2919215.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值