POJ 2299:Ultra-QuickSort

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 39397 Accepted: 14204

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

归并排序。

另外,此题有一坑就是结果会超int32;

详细能够參考:点击打开链接


我写的代码例如以下:


#include<cstdio>
#include<stdlib.h>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 500000 + 5;
int n, A[M], T[M], i;

long long merge_sort(int l, int r, int *A)
{
    if (r - l < 1) return 0;
    int mid = (l + r) / 2;
    long long ans = merge_sort(l, mid, A) + merge_sort(mid + 1, r, A);
    i = l;
    int p = l, q = mid + 1;
    while (p <= mid && q <= r)
    {
        if(A[p] <= A[q])
            T[i++] = A[p++];
        else
        {
            ans += (mid + 1 - p);
            T[i++] = A[q++];
        }
    }
    while (p <= mid) T[i++] = A[p++];
    while (q <= r) T[i++] = A[q++];
    for (int j = l; j <= r; j++)
        A[j] = T[j];
    return ans;
}

int main()
{
    int n;
    while(scanf("%d", &n) && n)
    {
        for(int j=0; j<n; j++)
            scanf("%d", &A[j]);
       printf("%lld\n", merge_sort(0, n - 1, A));
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值