android项目模块导入eclipse编译报错,android中studio导入eclipse项目报错怎么办

android中studio导入eclipse项目报错怎么办

发布时间:2020-07-15 17:34:45

来源:亿速云

阅读:96

作者:清晨

这篇文章将为大家详细讲解有关android中studio导入eclipse项目报错怎么办,小编觉得挺实用的,因此分享给大家做个参考,希望大家阅读完这篇文章后可以有所收获。

Android Studio导入Eclipse项目报错Error:Could not determine the class-path for interface com.android.builder.model.AndroidProject如图

14d5ba1b41e2e8ea967c229ebbdd6cd7.png

错误原因

因为Eclipse所使用的ADT插件已经不再更新,所以从Eclipse导出的项目使用的是旧版本Gradle插件,而新版的Android Studio(v2.3+)已经不再支持1.0.0版本以下的Gradle插件,因此报错。 相应的解决办法就是将配置文件中的Gradle插件版本,以及Gradle版本改成较新的版本。

解决步骤:

1、更改项目配置文件

打开项目的build.gradle文件(不是app Module下的)将classpath配置中的Gradle插件版本改为较新的版本,然后保存。如图:

caadb013a00a48bb2a504235475a0872.png

另:查看本地安装了哪个版本的Gradle Build Tool

打开Android Studio的安装目录,注意不是SDK安装目录或项目文件所在目录。在Android Studio的安装目录中,找到以下文件夹:gradle\m2repository\com\android\tools\build\gradle\可以看到本机已经安装了哪些版本的Gradle插件。如图:

7f099a7f13dad6632888b9d2e850ce48.png

2、更改项目所用的Gradle版本

注意这里更改的是Gradle版本,不是Gradle插件版本。修改成Android Studio较新版

cedf2182c41457b761624a0f1b75035a.png

3、重新编译项目

点击工具栏中的Build -> Clean Project重新编译项目即可。

用的AndroidStudio版本为3.1,还会提示下图,点击自动修复即可

5e07725d5fb3ab1beb42c73d5f169667.png

关于android中studio导入eclipse项目报错怎么办就分享到这里了,希望以上内容可以对大家有一定的帮助,可以学到更多知识。如果觉得文章不错,可以把它分享出去让更多的人看到。

参与评论 您还未登录,请先 登录 后发表或查看评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:游动-白 设计师:我叫白小胖 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值