flip game java_poj1753,Flip Game

Flip Game

Time Limit: 1000MS

Memory Limit: 65536K

Total Submissions: 30449

Accepted: 13232

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each

round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

14b4b3ec0b5261bea3a5ad9f1313252c.pngConsider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the

goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb

bbwb

bwwb

bwww

Sample Output

4

Source

import java.util.ArrayDeque;

import java.util.Scanner;

/*

* 首先有两点:

* 1.两颗棋子的翻动顺序不影响翻动结果

* 2.一颗棋子的偶数次翻动与0次翻动效果等同,一颗棋子的奇数次翻动与1次翻动效果等同

*

*/

public class poj1753 {

public static void main(String[] args) {

Scanner cin=new Scanner(System.in);

while (cin.hasNext()){

ArrayDeque qu=new ArrayDeque();//Java队列

Node node=new Node(0,0,0);

for (int i=1;i<=4;i++){

String s=cin.next();

for (int j=0;j

char c=s.charAt(j);

if (c=='b') {

node.state=(node.state<<1)+1;//黑棋子则将当前状态表示的二进制位设为1

}else{

node.state=node.state<<1;//白棋子则将当前状态表示的二进制位设为0

}

}

}

qu.add(node);//初始状态加入队列

boolean flag=false;

while (qu.size()!=0){

Node tou=qu.pop();//队头出队,以此队头衍生出下一颗棋子的翻动,并加入队尾

if (tou.state==0 || tou.state==(1<<16)-1){//(1<<16)-1的二进制位为16个1

System.out.println(tou.ways);//找到方法输出翻动棋子数

flag=true;

break;

}

if (qu.size()>0xFFFF) continue;//所有可能状态全部入队,不在有新的状态入队,以下循环体不再执行

for (int i=tou.location+1;i<=16;i++){//从当前头节点的位置向后找,1到16表示16个棋格的翻动

//状态(后修改),当前为第i个棋格的翻动,翻动棋格数为队头棋格翻动数+1

node=new Node(0,i,tou.ways+1);

//翻动当前棋子:队头与当前棋格翻动状态(例如左上角i=1状态为1后15个 0,即1000000000000000)的“异或”

node.state=tou.state^(1<

//翻动上相邻棋子:i-4>=1判断当前棋格是否有上相邻棋子

if (i-4>=1) node.state^=1<

//翻动下相邻棋子:i+4<=16判断当前棋格是否有下相邻棋子

if (i+4<=16) node.state^=1<

//翻动右相邻棋子:4的倍数为棋盘的右边界,无右相邻棋子,16-i再减1位运算少向左移动一位,所以是右边

if (i%4!=0) node.state^=1<

//翻动左相邻棋子:i-1为有边界时,加1后的i就是左边界

if ((i-1)%4!=0) node.state^=1<

qu.add(node);

}

}

if (!flag)//找不出合适翻动

System.out.println("Impossible");

}

}

}

class Node{

int state;//状态:state的二进制位表示16个棋格的状态

int location;//位置:当前状态为第i个棋格的翻动

int ways;//翻动棋格数

Node (int state,int location,int ways){

this.state=state;

this.location=location;

this.ways=ways;

}

}

java的ArrayDeque的使用

原文:http://blog.csdn.net/ieayoio/article/details/38236555

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值