这题看是否

这题能A是侥幸,解决的办法是先存一下输入的字符串,进行排序。

Problem Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable: A:01 B:10 C:0010 D:0000
but this one is not: A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

 

Input

Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

 

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

 

Sample Input

01 10 0010 0000 9 01 10 010 0000 9

 

Sample Output

Set 1 is immediately decodable Set 2 is not immediately decodable

 

#include <iostream>
 #include <stdio.h>
 #include <string.h> 
#include <stdlib.h>
 using namespace std; 
typedef struct Node 
{    
    struct Node *next[2];
     int flag;
 }Node,*Tree; 
int flag1;
 void Creat(Tree &T) 
{    
   T=(Node *)malloc(sizeof(Node));  
   T->flag=0;   
   for(int i=0;i<2;i++)    
      T->next[i]=NULL;
 } 
void insert(Tree &T,char *s) 
{    
    Tree p=T;  
    int t;     
    int l=strlen(s);  
   for(int i=0;i<l;i++) 
    {     
        t=s[i]-'0';     
       if(p->next[t]==NULL)   
          Creat(p->next[t]); 
        p=p->next[t];        
       if(p->flag>0)           
        flag1=0;   
  }    
      p->flag++; 
} 
void D(Tree p)
 {    
    for(int i=0;i<2;i++) 
    {       
       if(p->next[i]!=NULL)  
           D(p->next[i]);   
    }     
     free(p); 
} 
int main() 
{    
    char a[30];    
    int kk=0; 
    Tree T;    
   while(scanf("%s%*c",a)!=EOF)  
   {        
      Creat(T);     
      kk++;   
      flag1=1;   
      insert(T,a);   
      while(scanf("%s",a)!=EOF)    
     {             
        if(strcmp(a,"9")==0)    
             break;      
         insert(T,a);  
       }       
      if(flag1)        
     printf("Set %d is immediately decodable\n",kk);
       else printf("Set %d is not immediately decodable\n",kk);       
  D(T);
    }   
  return 0; 
}
  • 1.
  • 2.
  • 3.
  • 4.
  • 5.
  • 6.
  • 7.
  • 8.
  • 9.
  • 10.
  • 11.
  • 12.
  • 13.
  • 14.
  • 15.
  • 16.
  • 17.
  • 18.
  • 19.
  • 20.
  • 21.
  • 22.
  • 23.
  • 24.
  • 25.
  • 26.
  • 27.
  • 28.
  • 29.
  • 30.
  • 31.
  • 32.
  • 33.
  • 34.
  • 35.
  • 36.
  • 37.
  • 38.
  • 39.
  • 40.
  • 41.
  • 42.
  • 43.
  • 44.
  • 45.
  • 46.
  • 47.
  • 48.
  • 49.
  • 50.
  • 51.
  • 52.
  • 53.
  • 54.
  • 55.
  • 56.
  • 57.
  • 58.
  • 59.
  • 60.
  • 61.
  • 62.
  • 63.
  • 64.
  • 65.
  • 66.
  • 67.