ping 不通 华为三层交换机vlan_华为三层交换机5700系列配置方法示例教程注意事项...

说说遇见一个故障,新机5700,连接 5720,光口不亮,测试各部分无故障,百思不得其姐,问华为,告之,结果,是要注意,5720并不是全自适应。

552107369260ec47233d5f316e7134d8.png
e276bebf0ec9d64be5807c498a67d95d.png
678e6bb25a118a93d21aa893e241d839.png

马上换上,光亮,问题解决

2af8751342b341844a3edddcdc71f915.png
f9858237901abb3998eb7283b8745e73.png

整理一下,方便使用

 华为交换机配置

首先需要使用通讯控制线缆(包装中附)连接电脑和交换机,一头接交换机的Console口,一头接电脑com口(应该需要串口,没有的话得用USB转串口).

在PC机上运行终端仿真程序,设置终端通信参数为:波特率为9600bit/s、8位数据位、1位停止位、无校验和无流控,并选择终端类型为VT100.

(win7是不带终端仿真程序的,可以自行从网上搜索下载“win7 超级终端”)

75ede16c9f906ac83fe7b687fe845e8c.png

第一次连接上交换机后,会提示你配置交换机的管理密码,输入后回车,再输入一次确认回车。

此时来到命令

默认交换机是没有初始IP的,那么我们先来配置一个(同时将电脑网线与交换机上的任意以太网口连接)

sys

[Quidway]int vlan 1

[Quidway vlan 1]ip add 192.168.1.2 255.255.255.0 (这里配置的IP地址要和电脑网线IP是同个网段哦,访问web界面要用)

[Quidway vlan 1]q

[Quidway]q

好的,交换机IP配置完毕。

dir

发现有个web.7z的文件,这就是web管理页面的文件包,记下完整文件名下面要用。

sys (进入系统视图)

[Quidway]http server load web.7z (加载web包)

[Quidway]http server enable (开启http服务)

[Quidway]aaa (进入aaa视图)

[Quidway-aaa]local-user admin password cipher admin123 (配置管理账号与密码)

[Quidway-aaa]local-user admin privilege level 3 (配置管理账号级别)

[Quidway-aaa]local-user admin service-type http (配置接入类型为http)

[Quidway-aaa]q (退出)

[Quidway]q (退出)

save (保存)

Y (确认)

卡摸北鼻~!现在打开浏览器登录你刚才给交换机配置的IP吧,

示例教程

华为三层交换机5700系列配置示例教程。配置说明 配置华为交换机的注意事项(针对5700系列) 默认情况下,华为设备管理地址为192 168 1 253 24, 账号 admin, 密码 admin@huawei com 如果有web界面管理功能。

配置说明 配置华为交换机的注意事项(针对5700系列) 默认情况下,华为设备管理地址为192.168.1.253/24, 账号 admin, 密码 admin@huawei.com 如果有web界面管理功能,可以尝试使用ETH口登陆,如果登陆不上,可以按住MODE键6s,重置,打开web登陆功能。 在配三层交换机配置vlan时,默认情况下不同的vlan网段是可以通过路由互通的,不用额外配置(如思科等设备需要开启ip routing) 如果要对端口批量操作,如配置vlan,可以先创建一个组,使用 port-group GROUP-NAME命令创建组,并通过group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/20来批量添加组员,以后需要对这些端口操作进入此group就可以了。 如果要对不同的vlan网络隔离,需要配置ACL策略。 在使用PC机进行测试时,要关闭无线和其他的虚拟网卡,并确认关闭防火墙,排除测试干扰因素。 实现方式

三层核心交换机在配置多个不同网段互联时,有以下两种方式:

1. 单臂路由方式: 三层核心交换机配置多网络vlan,与上联汇聚层设备接口使用trunk透传,上联防火墙或路由器创建子接口并对应VLAN作为网关,vlan间的数据路由在上联设备完成。

单臂路由方式:

2. 静态路由方式: 三层核心交换机作为接入设备,配置多网络vlan,并创建网关,上联接口配置静态IP,交换机和上联设备添加静态路由,vlan之间的数据路由在接入交换机上完成。

静态路由方式:

设备配置 单臂路由方式(Trunk)

路由器:

LAN1: 192.168.1.1 下一跳地址: 192.168.1.2

SW1

GE1/0/1: 192.168.1.2 VLAN 1 GE1/0/2: TRUNK 允许 VLAN 2 3 GE1/0/3: 192.168.4.1 VLAN 4

SW2

GE1/0/1: TRUNK VLAN 2 3 GE1/0/23: 192.168.2.1/24 VLAN 2 GE1/0/24: 192.168.3.1/24 VLAN 3

SW3默认不用配置,充当二层交换机

配置思路

采用如下的思路配置汇聚层设备作为网关实现不同网段用户间的通信:

配置接入交换机,基于接口划分VLAN,实现二层互通。 配置汇聚交换机作为用户PC的网关,实现不同网段用户PC间的三层互通。 配置汇聚交换机与路由器相连的接口,实现与路由器的互连。 1.路由器配置

路由器(或者防火墙)的配置非常简单,只需要在LAN口配置静态IP,并配置上到网关交换机的静态路由地址。

# 配置子接口,lan

interface Vlanif1

ip address 192.168.1.1 255.255.255.0

# 配置静态路由,内网的下一跳地址为汇聚交换机的接口地址

ip route-static 192.168.0.0 255.255.0.0 192.168.1.2

2.交换机SW2配置

1.创建VLAN。

system-view

[HUAWEI] sysname SW2 # 修改设备的名称为SW2,便于识别

[SW2] vlan batch 2 3 //批量创建VLAN 2和VLAN 3

[SW2] interface gigabitethernet 1/0/23

[SW2-GigabitEthernet1/0/23] port link-type access //将与PC相连接口的接口类型设置为access

[SW2-GigabitEthernet1/0/23] port default vlan 2 //将PC1划分到VLAN 2

[SW2-GigabitEthernet1/0/23] quit

[SW2] interface gigabitethernet 1/0/24

[SW2-GigabitEthernet1/0/24] port link-type access

[SW2-GigabitEthernet1/0/24] port default vlan 3 //将PC2划分到VLAN 3

[SW2-GigabitEthernet1/0/24] quit

[SW2] interface gigabitethernet 1/0/1

[SW2-GigabitEthernet1/0/1] port link-type trunk //将与汇聚交换机相连接口的接口类型设置为trunk

[SW2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 3 //透传VLAN 2和VLAN 3到汇聚交换机SW1

[SW2-GigabitEthernet1/0/1] quit

3.配置汇聚交换机SW1

1.创建vlan

system-view

[HUAWEI] sysname SW1 //修改设备的名称为SW1

[SW1] vlan batch 2 to 4 //批量创建VLAN 2到VLAN 4

2.将连接PC的接口加入相应VLAN。

[SW1] interface gigabitethernet 1/0/2

[SW1-GigabitEthernet1/0/2] port link-type trunk //将与SW1相连接口的接口类型设置为trunk

[SW1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3 //透传VLAN 2和VLAN 3

[SW1-GigabitEthernet1/0/2] quit

[SW1] interface gigabitethernet 1/0/3

[SW1-GigabitEthernet1/0/3] port link-type access //将与PC3相连接口的接口类型设置为access

[SW1-GigabitEthernet1/0/3] port default vlan 4 //将PC3划分到VLAN 4

[SW1-GigabitEthernet1/0/3] quit

3.配置VLANIF接口,作为用户PC的网关。

[SW1] interface vlanif 2 //创建VLANIF2接口

[SW1-Vlanif2] ip address 192.168.2.1 24 //配置IP地址,此IP地址是PC1的网关地址

[SW1-Vlanif2] quit

[SW1] interface vlanif 3 //创建VLANIF3接口

[SW1-Vlanif3] ip address 192.168.3.1 24 //配置IP地址,此IP地址是PC2的网关地址

[SW1-Vlanif3] quit

[SW1] interface vlanif 4 //创建VLANIF4接口

[SW1-Vlanif4] ip address 192.168.4.1 24 //配置IP地址,此IP地址是PC3的网关地址

[SW1-Vlanif4] quit

将连接路由器的接口加入相应VLAN。

[SW1] interface Vlanif1

[SW1] ip address 192.168.1.1 255.255.255.0

[SW1] interface gigabitethernet 1/0/1

[SW1-GigabitEthernet1/0/1] port link-type access //将与路由器相连接口的接口类型设置为access,与 路由器通过Untagged方式通信 ,默认为VLAN1

[SW1-GigabitEthernet1/0/1] quit

[SW1] ip route-static 0.0.0.0 0.0.0.0 192.168.1.1 // 配置一条到路由器的缺省路由

4. 检查配置结果

dis cu

PC1、PC2、PC3之间可以相互访问,同时PC都可以和路由器进行通信。

静态路由方式(无trunk)

路由器

GE1/0/1: 192.168.1.1

SW1(可按照如下配置,也可以全部配置为vlan1或vlan5)

GE1/0/1: 192.168.1.2 VLAN 1 GE1/0/2: 192.168.5.1 VLAN 5 GE1/0/3: 192.168.5.1 VLAN 5

SW2

GE1/0/1: 192.168.5.2 VLAN 5 GE1/0/23: 192.168.2.1 VLAN 2 GE1/0/24: 192.168.3.1 VLAN 3

SW3

GE1/0/1: 192.168.5.3 VLAN 5 GE1/0/2: 192.168.4.1 VLAN 4 配置思路

采用如下的思路配置接入层设备作为网关实现不同网段用户间的通信:

配置接入交换机,基于接口划分VLAN,实现二层互通。 配置接入交换机作为PC的网关,实现不同网段用户间通信。 配置汇聚交换机静态路由,实现用户和路由器的互通 1.路由器配置

路由器(或者防火墙)的配置非常简单,只需要在LAN口配置静态IP,并配置上到网关交换机的静态路由地址。

# 配置子接口,lan

interface Vlanif1

ip address 192.168.1.1 255.255.255.0

# 配置静态路由

ip route-static 192.168.0.0 255.255.0.0 192.168.1.2

2.交换机SW2配置 创建VLAN。

system-view

[HUAWEI] sysname SW2 //修改设备的名称为SW2,便于识别

[SW2] vlan batch 2 to 3 //批量创建VLAN 2和VLAN

将接口加入相应VLAN

[SW2] interface gigabitethernet 1/0/23

[SW2-GigabitEthernet1/0/23] port link-type access //将与PC相连接口的接口类型设置为access

[SW2-GigabitEthernet1/0/23] port default vlan 2 //将PC1划分到VLAN 2

[SW2-GigabitEthernet1/0/23] quit

[SW2] interface gigabitethernet 1/0/24

[SW2-GigabitEthernet1/0/24] port link-type access

[SW2-GigabitEthernet1/0/24] port default vlan 3 //将PC2划分到VLAN 3

[SW2-GigabitEthernet1/0/24] quit

配置VLANIF接口,作为用户PC的网关。

[SW2] interface vlanif 2 //创建VLANIF2接口

[SW2-Vlanif2] ip address 192.168.2.1 24 //配置IP地址,此IP地址是PC1的网关地址

[SW2-Vlanif2] quit

[SW2] interface vlanif 3 //创建VLANIF3接口

[SW2-Vlanif3] ip address 192.168.3.1 24 //配置IP地址,此IP地址是PC2的网关地址

[SW2-Vlanif3] quit

4.配置SW2和SW1互连

[SW2] vlan batch 5 //创建VLAN 5

[SW2] interface gigabitethernet 1/0/1

[SW2-GigabitEthernet1/0/1] port link-type access

[SW2-GigabitEthernet1/0/1] port default vlan 5 //SW2和SW1以Untagged方式通信

[SW2-GigabitEthernet1/0/1] quit

[SW2] interface vlanif 5 //创建VLANIF5接口

[SW2-Vlanif5] ip address 192.168.5.2 24 //配置IP地址,此IP地址是SW2与SW1互连接口的IP地址

[SW2-Vlanif5] quit

[SW2] ip route-static 0.0.0.0 0.0.0.0 192.168.5.1 //配置缺省路由,为PC用户找到访问路由器的出口。 缺省路由的下一跳是SW1相连接口的IP地址

3.配置接入交换机SW3 创建VLAN

system-view

[HUAWEI] sysname SW3 //修改设备的名称为SW3

[SW3] vlan batch 4 //批量创建VLAN 4

将接口加入相应VLAN。

[SW3] interface gigabitethernet 1/0/2

[SW3-GigabitEthernet1/0/2] port link-type access //将与PC相连接口的接口类型设置为access

[SW3-GigabitEthernet1/0/2] port default vlan 4 //将PC3划分到VLAN 4

[SW3-GigabitEthernet1/0/2] quit

配置SW3和SW1互连

[SW3] vlan batch 5 //创建VLAN 5

[SW3] interface gigabitethernet 1/0/1

[SW3-GigabitEthernet1/0/1] port link-type access

[SW3-GigabitEthernet1/0/1] port default vlan 5 //SW3和SW1以Untagged方式通信

[SW3-GigabitEthernet1/0/1] quit

[SW3] interface vlanif 5 //创建VLANIF5接口

[SW3-Vlanif5] ip address 192.168.5.3 24 //配置IP地址,此IP地址是SW3与SW1互连接口的IP地址

[SW3-Vlanif5] quit

[SW3] ip route-static 0.0.0.0 0.0.0.0 192.168.5.1 //配置缺省路由,为PC用户指定访问路由器的出口。 缺省路由的下一跳是SW1相连接口的IP地址

4.配置汇聚交换机SW1 创建VLAN

system-view

[HUAWEI] sysname SW1 //修改设备的名称为SW1

[SW1] vlan batch 5 //批量创建VLAN 5

将连接PC的接口加入相应VLAN

[SW1] interface gigabitethernet 1/0/1

[SW1-GigabitEthernet1/0/1] port link-type access //将与路由器相连接口的接口类型设置为access

[SW1-GigabitEthernet1/0/1] port default vlan 1

[SW1-GigabitEthernet1/0/1] quit

[SW1] interface gigabitethernet 1/0/2

[SW1-GigabitEthernet1/0/2] port link-type access //将与SW2相连接口的接口类型设置为access

[SW1-GigabitEthernet1/0/2] port default vlan 5

[SW1-GigabitEthernet1/0/2] quit

[SW1] interface gigabitethernet 1/0/3

[SW1-GigabitEthernet1/0/3] port link-type access //将与SW3相连接口的接口类型设置为access

[SW1-GigabitEthernet1/0/3] port default vlan 5

[SW1-GigabitEthernet1/0/3] quit

3.配置VLANIF接口,实现和路由器的互连

[SW1] interface vlanif 5 //创建VLANIF5接口

[SW1-Vlanif5] ip address 192.168.5.1 24 //配置IP地址,此IP地址是与接入交换机对接的IP地址

[SW1-Vlanif5] quit

[SW1] interface vlanif 1

[SW1-Vlanif1] ip address 192.168.1.2 24 //配置IP地址,此IP地址是与路由器对接的IP地址

[SW1-Vlanif1] quit

配置回程明细路由,实现内网网段之间互访。

[SW1] ip route-static 192.168.2.0 255.255.255.0 192.168.5.2 //目的IP是192.168.2.0/24网段的,下 一跳是192.168.5.2,该IP地址对应SW2相连接口VLANIF的IP地址

[SW1] ip route-static 192.168.3.0 255.255.255.0 192.168.5.2 //目的IP是192.168.3.0/24网段的,下 一跳是192.168.5.2,该IP地址对应SW2相连接口VLANIF的IP地址

[SW1] ip route-static 192.168.4.0 255.255.255.0 192.168.5.3 //目的IP是192.168.4.0/24网段的,下 一跳是192.168.5.3,该IP地址对应SW3相连接口VLANIF的IP地址

配置缺省路由,实现内网网段到路由器的访问

[SW1] ip route-static 0.0.0.0 0.0.0.0 192.168.1.1 //假设路由器与SW1相连接口的IP地址是 192.168.1.1

5.检查配置结果

PC1、PC2、PC3之间可以相互访问,同时PC都可以和路由器进行通信。

补充说明 如果要在网关上开启DHCP,使用如下命令

# 全局开启dhcp

dhcp enable

dhcp server database enable

# 在子接口上配置dhcp

interface Vlanif20

ip address 192.168.20.254 255.255.255.0

dhcp select interface

# 设置保留分配的IP

dhcp server excluded-ip-address 192.168.20.201 192.168.20.253

# 设置DHCP缓存时间

dhcp server lease day 0 hour 8 minute 0

# 设置DNS

dhcp server dns-list 8.8.8.8 114.114.114.114

设置ETH管理接口IP

interface MEth 0/0/1

ip address 192.168.0.1 24

华为S5700交换机初始化和配置SSH和TELNET远程登录方法

基础设置:

配置登陆IP地址

system-view //进入系统配置模式

[Quidway]interface Vlanif 1 //进入三层 vlanif 接口

[Quidway-Vlanif1]ip address 192.168.0.1 255.255.255.0 //配置管理 IP 地址

创建web登录管理账号

[Quidway]http server enable ///系统视图下开启http服务

[Quidway]http secure-server enable ///系统视图下开启http安全服务 即https

[Quidway]aaa //系统视图下进入aaa模式

[Quidway-aaa]local-user admin privilege level 15 ///配置 http 登录名权限

[Quidway-aaa]local-user admin service-type http /// 开启 http 登录服务

[Quidway-aaa]quit /// 退出aaa模式

如果telnet能登录,但console反而不能登录的话,则需在aaa里 把要登录的 账户 赋予权限

[Quidway-aaa]local-user admin service-type terminal ssh telnet ftp

创建vlan

system-view ///进入系统配置模式

[Quidway]vlan 10 ///创建vlan 10

[Quidway-vlan10]quit ///退出系统配置模式

[Quidway]interface Vlanif 10 ///进入配置vlan 10的模式

[Quidway-Vlanif10]ip address 192.168.0.1 255.255.255.0 ///为vlan 10配置IP地址和掩码

[Quidway-vlan10]quit ///退出系统配置模式

[Quidway-GigabitEthernet0/0/2] ///进入端口2

[Quidway-GigabitEthernet0/0/2]port link-type access ///端口类型设置为access

[Quidway-GigabitEthernet0/0/2]port default vlan 10 ///将port加入到我们创建好的vlan 10

[Quidway-GigabitEthernet0/0/2]display vlan ///查看配置的vlan信息

[Quidway]q ///退出系统设置视图

批量创建vlan

system-view ///进入系统配置模式

[Quidway]vlan batch 2 to 19 ///批量创建vlan 2-19 ,系统都会有一个默认的vlan 1

[Quidway]display vlan ///查看vlan信息

[Quidway]q ///退出系统设置视图

批量删除vlan

system-view ///进入系统配置模式

[Quidway]undo vlan batch 2 to 19 ///批量删除vlan 2-19 ,系统都会有一个默认的vlan 1

[Quidway]display vlan ///查看vlan信息

[Quidway]q ///退出系统设置视图

批量把端口加入到vlan 10

system-view ///进入系统配置模式

[Quidway]interface range GigabitEthernet 0/0/1 to GigabitEthernet 0/0/6

///将1口到6口添加到port-group,此处系统默认的给1口到6口添加到1个组里了。

[Quidway-port-group]port link-type access ///将port-group组内的端口全部改为access口

[Quidway-port-group]port default vlan 10 ///将port-group组内的端口全部加入到vlan 10

[Quidway]q ///退出系统设置视图

或者先创建一个端口组,再添加到vlan中

system-view ///进入系统配置模式

[Quidway]port-group 1 ///创建端口组,组名为1

[Quidway-port-group-1]group-member GigabitEthernet 0/0/7 to GigabitEthernet 0/0/17 ///把端口7到17添加到端口组1中

[Quidway-port-group-1]port link-type access ///将port-group-1组内的端口全部改为access口

[Quidway-port-group-1]port default vlan 20 ///将port-group-1组内的端口全部加入到vlan 20

[Quidway-port-group-1]display vlan ///查看配置的vlan信息

[Quidway-port-group-1]q ///退出端口组1的配置模式

[Quidway]q ///退出系统设置视图

删除vlan----需要先删除vlanif信息---再删vlan

system-view ///进入系统配置模式

[Quidway]undo interface Vlanif 10 ///删除vlanif 10

[Quidway]display vlan ///查看vlan配置

[Quidway]display current-configuration ///发现vlan配置还在,vlanif配置已经不在

[Quidway]undo vlan 10 ///删除vlan 10

[Quidway]display vlan ///查看vlan配置,发现vlan 10已经不在

[Quidway]display current-configuration ///发现vlan配置不在,vlanif配置也不在,但是port信息还有,单独删port信息太慢

批量删除port信息

对于上面我们已经把vlanif信息删除,vlan删除,但是display current-configuration发现

之前创建的port信息还是在的,一个一个删太慢,这里我们还创建组去删

system-view ///进入系统配置模式

[Quidway]port-group 2 ///创建port组2

[Quidway-port-group-2]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/6 ///将1口到6口加入到port组2中

[Quidway-port-group-2]undo port default vlan ///将port组2内的端口vlan配置全部删除

[Quidway-port-group-2]undo port link-type ///将port组2内的端口类型全部恢复到默认

[Quidway-port-group-2]display current-configuration ///查看端口信息

[Quidway-port-group-2]q ///退出端口组1的配置模式

[Quidway]q ///退出系统设置视图

华为S5700交换机初始化和配置TELNET远程登录方法:

1,交换机开启Telnet服务

system-view #进入系统视图

[Huawei]telnet server ? #查看有enable还是disable选项,选择对应的开启方式。

[Huawei]telnet server enable #enable选项开启Telnet服务 (普通系列一般为这个)

[Huawei]undo telnet server disable #disable选项开启Telnet服务 (CE高端系列一般为这个)

2,配置VTY用户界面的最大个数(同时可以登录的最大数)

[Huawei]user-interface maximum-vty 15 #默认是5,这个可以不设置

3,配置VTY用户界面的终端属性

[Huawei]user-interface vty 0 14 #上面是15所有这里是0 14 如果选择默认这里是0 4

[Huawei-ui-vty0-14]protocol inbound telnet #配置vty支持telnet协议

4,配置VTY用户界面的用户验证方式

[Huawei-ui-vty0-14]authentication-mode aaa #配置用户终端的身份验证模式为aaa认证为aaa认证

[Huawei-ui-vty0-14]quit #退出vty配置界面

5,配置登录验证方式

[Huawei]aaa #进入aaa配置模式

[Huawei-aaa]local-user admin1234 password ? #查看可以选择的密码选择

[Huawei-aaa]local-user admin1234 password simple Huawei12#$ #密码选项simple 账号admin1234 密码Huawei12#$ (普通系列一般为这个)

[Huawei-aaa]local-user admin1234 password irreversible-cipher Huawei12#$ #密码选项irreversible-cipher 账号admin1234 密码Huawei12#$ (CE高端系列一般为这个)

[Huawei-aaa]local-user admin1234 service-type telnet #配置接入服务类型,如果还需要SSH登录请加上

[Huawei-aaa]local-user admin1234 privilege level 3 #配置账号的级别,默认3级是超级管理员的权限

[Huawei-aaa]quit #退出

telnet 127.0.0.1 #测试telnet配置是否OK

save #保存配置

===================================================================

华为S5700交换机初始化和配置SSH和TELNET远程登录方法:

AAA是指:authentication(认证)、authorization(授权)、accounting(计费)的简称,是网络安全的一种管理机制;Authentication是本地认证/授权,authorization和accounting是由远处radius(远程拨号认证系统)服务或hwtacacs(华为终端访问控制系统)服务器完成认证/授权;AAA是基于用户进行认证、授权、计费的,而NAC方案是基于接入设备接口进行认证的,在实际应用中,可以使用AAA的一种或两种服务。

如果是一台刚初始化过的华为交换机,需要输入两次相同的密码作为登录交换机的登录密码

交换机上有console 端口 MEth管理端口 usb端口

通过串口线配置S5700 的管理IP地址,串口线接在交换机的console口,ip设置完成后网线接在ETH口:

system-view

[Quidway] interface MEth 0/0/1

[Quidway] interface MEth 0/0/1

[Quidway-MEth0/0/1]ip address x.x.x.x 255.255.255.0 ///设置MEth管理端口的ip地址

[Quidway-MEth0/0/1]quit

[Quidway]ip route-static 0.0.0.0 0.0.0.0 x.x.x.x(gateway)

[Quidway-MEth0/0/1]display ip interface MEth 0/0/1 ///查看MEth管理端口的配置信息

[Quidway]

添加用户,设置ssh telent远程登录

system-view ///进入系统配置模式

[Quidway]aaa ///进入AAA模式

[Quidway-aaa]local-user chy password cipher qaz123456 ///设置本地用户名和密码 cipher加密

[Quidway-aaa]local-user chy service-type ssh telnet terminal ///设置用户设置登录ssh telnet terminal服务

[Quidway-aaa]display ssh server status ///查看ssh服务是否生效

[Quidway-aaa]display telnet server status ///查看telnet服务是否生效

[Quidway-aaa]local-user chy privilege level 15 ///设置用户级别

[Quidway-aaa]q ///退出AAA模式

设置vty 0 4远程登陆的虚拟端口

VTY是路由器的远程登陆的虚拟端口,0 4表示可以同时打开5个会话,line vty 0 4是进入VTY端口,对VTY端口进行配置,比如说配置密码,或者ACL.

[Quidway]user-interface vty 0 4 ///进入vty 0 4远程虚拟端口

[Quidway-ui-vty0-4]authentication-mode aaa ///为虚拟用户终端配置AAA身份验证模式

[Quidway-ui-vty0-4]user privilege level 15 ///为虚拟用户终端配置用户级别

[Quidway-ui-vty0-4]protocol inbound all ///为虚拟用户终端配置使用的协议,all即都支持

[Quidway-ui-vty0-4]protocol inbound telnet ///为虚拟用户终端配置telnet协议,即可以使用telnet远程登录

[Quidway-ui-vty0-4]protocol inbound ssh ///为虚拟用户终端配置ssh协议,即用户可以使用ssh远程登录

[Quidway]ssh user chy authentication-type password ///为chy用户设置ssh认证为password,此命令对设置单一用户设置来说比较实用

[Quidway]ssh authentication-type default password ///设置ssh默认的认证方式为密码认证,对设置多个用户来说很实用

[Quidway]ssh user chy service-type stelnet ///为chy用户设置ssh认证服务类型为stelnet

[Quidway]display ssh user-information chy ///查看ssh服务chy用户的配置信息

[Quidway]q ///退出系统设置视图

save ///保存设置

===================================================================

网摘文章一:

一、通过串口线配置S5700 的管理IP地址和网关,串口线接在交换机的console口,ip设置完成后网线接在ETH口:

system-view

[Quidway] interface Meth 0/0/1

[Quidway-Meth0/0/1]ip address x.x.x.x 255.255.255.0

[Quidway-Meth0/0/1]quit

[Quidway]ip route-static 0.0.0.0 0.0.0.0 x.x.x.x(gateway)

[Quidway]

如果交换机没有ETH口,且需要配置VLANIF:

system-view

[Quidway] interface vlanif3000

[Quidway--Vlanif3000]ip address x.x.x.x 255.255.255.0

[Quidway--Vlanif3000]quit

[Quidway]ip route-static 0.0.0.0 0.0.0.0 x.x.x.x(gateway)

[Quidway]

二、设置telnet登录S5700(eg.设置用户名admin密码112233):

system-view

[Quidway] user-interface vty 0 4

[Quidway-ui-vty0-4] authentication-mode aaa

[Quidway-ui-vty0-4]protocal inbound all

[Quidway-ui-vty0-4] user privilege level 15

[Quidway-ui-vty0-4]quit

[Quidway]telnet server enable

[Quidway] aaa

[Quidway-aaa] local-user admin password cipher 112233

[Quidway-aaa] local-user admin service-type telnet

[Quidway-aaa] local-user admin privilege level 15

[Quidway-aaa] quit

三、设置SSH登录5700(eg.设置用户名admin密码112233):

[Quidway]rsa local-key-pair create

The key name will be: Quidway_Host

% RSA keys defined for Quidway_Host already exist.

Confirm to replace them? [y/n]:y

The range of public key size is (512 ~ 2048).

NOTES: If the key modulus is greater than 512,

it will take a few minutes.

Input the bits in the modulus[default = 512]:

Generating keys...

...........++++++++++++

......++++++++++++

..........++++++++

...............++++++++

[Quidway] aaa

[Quidway-aaa] local-user admin password simple 112233

[Quidway-aaa] local-user admin service-type ssh

[Quidway-aaa] local-user admin privilege level 15

[Quidway-aaa] quit

[Quidway] stelnet server enable

Info: Succeeded in starting the Stelnet server.

[Quidway] ssh authentication-type default password

[Quidway]quit

save all

======================================================================

华为S5700 Telnet配置

system-view

[Quidway] vlan 10

[Quidway-vlan10] quit

[Quidway] interface gigabitethernet 0/0/1

[Quidway-GigabitEthernet0/0/1] port link-type hybrid

[Quidway-GigabitEthernet0/0/1] port hybrid untagged vlan 10

[Quidway-GigabitEthernet0/0/1] quit

[Quidway]interface vlanif 10

[Quidway-vlanif10] ip address 202.38.160.92 255.255.0.0

[Quidway-vlanif10] quit

[Quidway] aaa

[Quidway-aaa] local-user huawei password cipher hello

[Quidway-aaa] local-user huawei service-type telnet

[Quidway-aaa] local-user huawei level 3

[Quidway-aaa] quit

[Quidway] user-interface vty 0 4

[Quidway-ui-vty0-4] authentication-mode aaa

[Quidway-ui-vty0-4]quit

[Quidway]quit

save

======================================================================

网摘文章二:

1.在命令模式下:输入:systerm-view 进入系统视图模式

2.在系统视图模式命令行下:输入: aaa 进入AAA认证模式

3.添加远程登陆用户,并设置用户密码及密码加密方式

进入AAA模式命令行下:

输入 :local-user test password cipher welcome

添加新用户为:test 密码为:welcome 加密模式为:cipher 密文加密

4.设置完新添加用户后,输入:

local-user test service-type http ssh telnet web

设置哪些服务可以通过此test用户进行验证,设置telnet 服务

5.在AAA模式命令行下:

设置新添加的用户在命令行可以使用的命令级别,3为最高

local-user test level 3

设置完成后输入:quit 退回到系统视图模式

6.从系统视图模式输入:

user-interface vty 0 4

进入远程配置视图模式

然后在远程配置视图模式下,输入:

authentication-mode aaa

此配置意思为,远程连接使用AAA认证模式,远程连接时可以调用AAA模式中的用户来进行登录验证配置完成后保存然后就可以退出交换机了

  • 0
    点赞
  • 0
    评论
  • 2
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

打赏
文章很值,打赏犒劳作者一下
表情包
插入表情
评论将由博主筛选后显示,对所有人可见 | 还能输入1000个字符
相关推荐
©️2020 CSDN 皮肤主题: 深蓝海洋 设计师:CSDN官方博客 返回首页

打赏

春容

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者