1132 Cut Integer (20 分)

1132 Cut Integer (20 分)

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

 

解题思路:注意考虑划分为a和b时,b有可能为0的情况,如:1000,若不考虑则会出现浮点错误。

所以发生浮点错误应该考虑程序中:

 

写法1:(原始的粗鲁的写法)

再次使用了string转int函数:atoi(str.c_str());

  • 是否可能出现了一个数除以0的情况
  • 是否可能出现了一个数取余0的情况
  • 是否发生了数据溢出而导致的除以0或者取余0的情况
#include <iostream>
#include <bits/stdc++.h>
using namespace std;

bool devide(string s)
{
    int a = 0,b = 0;
    int len = s.size();
    for(int i = 0; i < len/2; i++){
        int d = s[i]-'0';
        a = a*10 + d;
    }
    for(int i = len/2; i < len; i++){
        int d = s[i]-'0';
        b = b*10 + d;
    }
    if(!a||!b) return false;
    int n = atoi(s.c_str());
    int c = n/(a*b);
    if(c*a*b==n) return true;
    else return false;
}


int main()
{
    string s;
    int n;
    cin >> n;
    while(n--){
        cin >> s;
        if(devide(s)) cout << "Yes\n";
        else cout << "No\n";
    }
    return 0;
}

 写法2:(利用stoi函数和substr函数)

int n = stoi(s)  //将s转换为int

s.substr(index,n) //从第index位开始取长度为n的子串

#include <iostream>
#include <bits/stdc++.h>
using namespace std;


int main()
{
    string s;
    int n;
    cin >> n;
    while(n--){
        cin >> s;
        int len = s.size(), d = stoi(s);
        int d1 = stoi(s.substr(0,len/2));
        int d2 = stoi(s.substr(len/2,len/2));
        if(d1*d2!=0 && d%(d1*d2)==0) cout << "Yes\n";
        else cout << "No\n";
    }
    return 0;
}

总结:PAT20分题一般比较简单,主要是看思路!思路正确可以短时间内快速完成,并且代码量也小,所以在练习简单题的时候一定要注意思路的总结,多看看别人的代码,锻炼解题的技巧和做题的速度。

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值