HDU 1022 Train Problem I

HDU 1022 Train Problem I

题目描述:

Train Problem I
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48735 Accepted Submission(s): 18382

Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.

Sample Input
3 123 321
3 123 312

Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint
Hint

For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.”.

求解:

很明显,改问题用栈来解决比较方便。代码中有详细的注释。

//Train Problem I
#include<stdio.h>
#include <stack> 
using namespace std; 

int main(){
	
	
	int n;
	while(~scanf("%d",&n)){
		char in[10],out[10]; //分别用来存放O1 和 O2两个串 
		int i;
		scanf("%s",in);
		scanf("%s",out);
		
		int res[18];		//要来存放入栈和出栈的序列,1表示入栈,-1表示出栈 
		int iIndex=0,oIndex=0,resIndex=0; //iIndex用来表示in[]数组的索引,oIndex用来表示out[]数组的索引,resIndex用来表示res[]数组的索引
		stack<char> mystack;//栈,用来保存中间的过程 
	
		while(iIndex<n){	//当in[]数组中还有序列时,就入栈 
			mystack.push(in[iIndex++]);
			res[resIndex++]=1;
			
			while(!mystack.empty()){	//如果栈非空,判断栈顶的元素是否和out[]序列的未读序列的第一个元素相同 
				if(mystack.top()==out[oIndex]){	//如果相同,则出栈 
					mystack.pop();
					oIndex++;
					res[resIndex++]=-1; 
				}else{							//如果不同,则退出内层循环 
					break;
				}
			}
		}
		if(mystack.empty()){	//如果栈为空,说明O1经过栈后可以转换成O2出去 
			printf("Yes.\n");
			for(i=0;i<resIndex;i++){	//输出进栈和出栈的序列 
				if(res[i]==1){
					printf("in\n");
				}else {
					printf("out\n");
				}
			}
			printf("FINISH\n");
		}else {
			printf("No.\n");
			printf("FINISH\n");
		}
	}

	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值