c语言输入日期确定星期

  • 题目描述
We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s
agreement about dating.
  • 输入
There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.
  • 输出
Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.
  • 样例输入
 9 October 2001 
 14 October 2001
  • 样例输出
 Tuesday 
 Sunday
  • 代码
//
//  main.c
//  判断星期
//
//  Created by fanaticheng on 2018/1/14.
//  Copyright © 2018年 fanc. All rights reserved.
//


#include <stdio.h>
#include <string.h>

#define LEAPYEAR(x) x % 100 != 0 && x % 4 == 0 || x % 400 == 0 ? 1 : 0
int dayOfMonth[13][2] = {
    0,0,
    31,31,
    28,29,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31
};
struct Date{
    int day;
    int month;
    int year;
    int weekday;
};
void NextDay(struct Date * date){
    date->day ++;
    if(date->day > dayOfMonth[date->month][LEAPYEAR(date->year)]){
        date->day = 1;
        date->month ++;
        if(date->month > 12){
            date->month = 1;
            date->year ++;
        }
    }
}
char Month[12][20] = {
    "January",
    "February",
    "March",
    "April",
    "May",
    "June",
    "July",
    "August",
    "September",
    "October",
    "November",
    "December"
};
char Weekday[7][20] = {
    "Monday",
    "Tuesday",
    "Wednesday",
    "Thursday",
    "Friday",
    "Saturday",
    "Sunday"
};

int main(int argc, const char * argv[]) {
    int inc1 = 0;
    int inc2 = 0;
    int day;
    char month[20];
    struct Date date1,date2,date3,date4;
    date3.year = 0;
    date3.month = 1;
    date3.day = 1;
    date4 = date3;
    while(scanf("%d",&date2.day) != EOF){
        scanf("%s",month);
        scanf("%d",&date2.year);
        int i = 0;
        while(i != 12){
            if(strcmp(month, Month[i]) == 0){
                date2.month = i + 1;
                break;
            }
            else i++;
        }
        if(i == 12){
            printf("ERROR MONTH!\n");
            return -1;
        }
        date1.year = 2001;
        date1.month = 10;
        date1.day = 9;
        date1.weekday = 2;
        while(!(date1.year == date3.year && date1.month == date3.month && date1.day == date3.day)){
            NextDay(& date3);
            inc1 ++;
        }
        while(!(date2.year == date4.year && date2.month == date4.month && date2.day == date4.day)){
            NextDay(& date4);
            inc2 ++;
        }
        if(inc1 >= inc2) day = inc1 - inc2;
        else day = inc2 - inc1;
        date2.weekday = ((date1.weekday + day % 7) % 7) - 1;
        if(date2.weekday == -1) printf("Sunday\n");
        else printf("%s\n",Weekday[date2.weekday]);
        }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值