PAT A1046 Shortest Distance

题意:
有N个结点围成一圈,相邻两个点之间的距离已知。且每次只能移动到相邻点。然后给出M个询问。每个询问给出两个数字A和B,即节点编
号(1<=A,B<=N),求从A号结点到B号结点的最短距离

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^5 ]), followed by N integer distances D1
, D​2 ⋯ DN, where D​i is the distance between the i-th and the (i+1)-st exits, and D​N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^​4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

#include <cstdio>
#include<algorithm>
using namespace std;
int dis[100005];
int i_1[100005];//第i个结点到第一个结点的距离,避免M个pair重复计算距离
int main()
{
    int N;
    int x,y,temp,ans;
    int total = 0;
    scanf("%d",&N);
    i_1[1] = 0;
    for(int i = 1;i<=N;i++){
        scanf("%d",&dis[i]);
        total+=dis[i];
        i_1[i+1] = total;
    }
    int M;
    scanf("%d",&M);
    for(int i = 1;i<=M;i++){
        ans = 0;
        scanf("%d%d",&x,&y);
        if(x>y){
            temp = x;
            x =y ;
            y = temp;
        }
        ans = i_1[y]-i_1[x];
        printf("%d\n",min(ans,total-ans));
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值