HDU - 1671 Phone List


Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES


题意:

求是否存在某串是另一个串的前缀


思路:

刚学字典树,可以用字典树,先存下所有字符串,然后按字典序从大到小排序。当添加节点时判断此时进去的字符串最后一个节点是否在另一个串中存在(此前已排序),若 cnt 值不为一则此串是某一个串的前缀。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;

//重点是简便的清空字典树的应用,用数组结构的清空效率高 

struct trie{
	trie *Next[15];
	char ch;
	int cnt;
}bee[1000005];

char s[25];
int f[15];
int o;//记录数组个数 
trie *creat(trie *root,char ch){
	root = &bee[o++];//赋值操作 ,相当于
//	root = (trie*)malloc(sizeof(root)); 
	
	
	for(int i = 0; i < 15; i++){
		root->Next[i] = NULL;
	}
	root->ch = ch;
	root->cnt = 1;
	
	return root;
}

int add(trie *root,char p[]){
	int len=strlen(p);
	int k;
	for(int i = 0; i < len; i++){
		
		if(root->Next[p[i]-'0'] == NULL){
			trie *r = creat(r,p[i]);
			root -> Next[p[i]-'0'] = r;
			root = root->Next[p[i]-'0'];
		}else{
			root = root->Next[p[i]-'0'];
			root ->cnt++;
		}
	}
	return root->cnt;
}


struct data{
	char s[25];
	int len;
}p[10005];


bool cmp(data a,data b){
	return a.len>b.len;
}

int main(){
	int tt,t;
	scanf("%d",&tt);
	while(tt--){
		o = 0;
		memset(f,0,sizeof(f));
		int flag=1;
		scanf("%d",&t);
		
		//清空字典树 
		for(int i = 0; i < t*15; i++){
			for(int j = 0; j < 15; j++){
				bee[i].Next[j] = NULL;
			}
		}
		
		trie *root;
		root = &bee[o++];
		for(int i = 0; i < t; i++){//存入结构体 
			scanf("%s",p[i].s);
			p[i].len=strlen(p[i].s);
		}
		sort(p,p+t,cmp);//排序方便查找 
		for(int i=0;i<t;i++){
			
			int k=add(root,p[i].s);
			if(k>1){
				flag=0;
				break;
			}
		}
		
		if(flag)printf("YES\n");
		else printf("NO\n");
	}
	
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值