HDU - 1495 非常可乐


大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
Sample Input
7 4 3
4 1 3
0 0 0
Sample Output
NO
3


思路:

循环爆搜,用BFS


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
int vis[105][105][105];

struct data{
	int b[3],step;
}p;
int temp[3];

void bfs(){
	memset(vis,0,sizeof(vis));
	queue<data>q;
	p.b[0]=temp[0];
	p.b[1]=0;
	p.b[2]=0;
	p.step=0;
	q.push(p);
	vis[p.b[0]][p.b[1]][p.b[2]]=1;
	while(!q.empty()){
		p=q.front();
		//只要三个瓶子有两个一样就可以平分 
		if((p.b[0]==temp[0]/2&&p.b[1]==temp[0]/2)||(p.b[0]==temp[0]/2&&p.b[2]==temp[0]/2)||(p.b[1]==temp[0]/2&&p.b[2]==temp[0]/2)){
			printf("%d %d %d\n",p.b[0],p.b[1],p.b[2]);
			printf("%d\n",p.step);
			return ;
		}
		q.pop();
		for(int i=0;i<3;i++){//倒水的杯 
			for(int j=0;j<3&&p.b[i]>0;j++){//接水的杯
				if(i==j)continue;
				data t=p;
				if(t.b[i]>=temp[j]-t.b[j]){
					t.b[i]-=(temp[j]-t.b[j]);
					t.b[j]=temp[j];
				}else{
					t.b[j]+=t.b[i];
					t.b[i]=0;
				}
				if(!vis[t.b[0]][t.b[1]][t.b[2]]){
					vis[t.b[0]][t.b[1]][t.b[2]]=1;
					t.step++;
					q.push(t);
				}
			} 
		}
	}
	printf("NO\n");
}

int main(){
	while(~scanf("%d%d%d",&temp[0],&temp[1],&temp[2])&&(temp[0]+temp[1]+temp[2])){
		if(temp[0]%2)printf("NO\n");
		else bfs();
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值