HDU - 1024 Max Sum Plus Plus


Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8


        
  
Hint
Huge input, scanf and dynamic programming is recommended.

        
 


题意:

求最大m段子序列和

(可以直接用模板)


代码:

#include<stdio.h>  
#include<algorithm>  
#include<string.h>  
#define N 1000000  
#define INF 0x3f3f3f3f
int a[N+5];  
int now[N+5];  
int pre[N+5];  
using namespace std;  

//最大m段和 (数组下标从一开始) 
int MaxSum(int m,int n,int *a){
	int maxx;
	memset(now,0,sizeof(now));  
    memset(pre,0,sizeof(pre));  
    for(int i=1;i<=m;i++)  
    {  
        maxx=-INF;  
        for(int j=i;j<=n;j++)  
        {  
            now[j]=max(now[j-1]+a[j],pre[j-1]+a[j]);  
            pre[j-1]=maxx;  
            if(now[j]>maxx)  
            {  
                maxx=now[j];  
            }  
        }  
    }  
    return maxx;
}

int main()  
{  
    int n,m,maxx,i,j;  
    while(scanf("%d%d",&m,&n)!=EOF)  
    {  
        for(i=1;i<=n;i++)  
        scanf("%d",&a[i]);  
        
        printf("%d\n",MaxSum(m,n,a));  
    }  
    return 0;  
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值