POJ - 2240 Arbitrage

Arbitrage
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 24453
Accepted: 10349

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

[Submit]   [Go Back]   [Status]   [Discuss]



题意:

已知两种货币的兑换汇率,求是否能通过几次兑换后使现在的货币增值

(可用距离数组代表钱数)


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<queue>
using namespace std;

int n,m;

double dis[35][35],dist[35];
int vis[35],num[35];

bool spfa()
{
	memset(vis,0,sizeof(vis));
	memset(num,0,sizeof(num));
	for(int i=1;i<=n;i++)
		dist[i]=0;
	
	queue<int>q;
	q.push(1);
	vis[1]=1;
	dist[1]=1.0;
	
	while(!q.empty())
	{
		int t=q.front();
		q.pop();
		
		vis[t]=0;
		for(int i=1;i<=n;i++)
		{
			if(dis[t][i] > 0 && dist[i] < dist[t]*dis[t][i])
			{
				dist[i] = dist[t]*dis[t][i];
				if(dist[1] > 1) return 1;
				//说明存在兑换几次后增值的现象 
				
				if(!vis[i])
				{
					vis[i]=1;
					q.push(i);
				}
			}
		}
	}
	return 0;
}

int main()
{
	string s;
	int t=1;
//	cin.sync_with_stdio(false);
	while(cin>>n,n)
	{
		map<string,int>k;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
				dis[i][j]=0;
			dis[i][i]=1;
			
			cin>>s;
			k[s]=i;
		}
		
		cin >> m;
		for(int i=1;i<=m;i++)
		{
			double p;
			string s1,s2;
			
			cin >> s1 >> p >> s2;
			
			dis[k[s1]][k[s2]]=p;
		}
		
		printf("Case %d: ",t++);
		if(spfa()) printf("Yes\n");
		else printf("No\n");
		
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值