For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G = (Gmid-termx 40% + Gfinalx 60%) if Gmid-term > Gfinal, or Gfinal will be taken as the final grade G. Here Gmid-term and Gfinal are the student's scores of the mid-term and the final exams, respectively.
The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.
Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.
Then three blocks follow. The first block contains P online programming scores Gp's; the second one contains M mid-term scores Gmid-term's; and the last one contains N final exam scores Gfinal's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).
Output Specification:
For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:
StudentID Gp Gmid-term Gfinal G
If some score does not exist, output "-1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qualified student.
Sample Input:6 6 7 01234 880 a1903 199 ydjh2 200 wehu8 300 dx86w 220 missing 400 ydhfu77 99 wehu8 55 ydjh2 98 dx86w 88 a1903 86 01234 39 ydhfu77 88 a1903 66 01234 58 wehu8 84 ydjh2 82 missing 99 dx86w 81Sample Output:
missing 400 -1 99 99 ydjh2 200 98 82 88 dx86w 220 88 81 84 wehu8 300 55 84 84
tips:
(1)G_p>=200,final grade<=100 && final grade >=60;
(2)final grade = G_mid>G_final?int(G_mid*0.4+G_final*0.6+0.5):G_final;
(3)利用map将id标记为int型,以便统计数据
(4)G_mid,G_final 初始化为-1
(5)符合(1)的学生,按final grade非递增排序,相等则按id递增排序
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
using namespace std;
const int maxn=30010;
struct node{
string id;
int p,mid,fin,g;
node()
{
p=mid=fin=-1;
}
}all[maxn],valid[maxn];
map<string,int> mp;
int num=0;
int getid(string id)
{
if(mp.find(id)!=mp.end())
return mp[id];
else
{
mp[id]=num;
return num++;
}
}
bool cmp(node a,node b)
{
if(a.g!=b.g)return a.g>b.g;
else return a.id<b.id;
}
int main()
{
int p,m,n;
cin>>p>>m>>n;
for(int i=0;i<p;i++)
{
string str;
int s;
cin>>str>>s;
int id=getid(str);
all[id].id=str;
all[id].p=s;
}
for(int i=0;i<m;i++)
{
string str;
int s;
cin>>str>>s;
int id=getid(str);
all[id].id=str;
all[id].mid=s;
}
for(int i=0;i<n;i++)
{
string str;
int s;
cin>>str>>s;
int id=getid(str);
all[id].id=str;
all[id].fin=s;
}
int len=0;
for(int i=0;i<num;i++)
{
if(all[i].mid>all[i].fin)
{
all[i].g=(int)(0.4*all[i].mid+0.6*all[i].fin+0.5);
}else
all[i].g=all[i].fin;
if(all[i].p>=200&&all[i].g>=60)
{
valid[len++]=all[i];
}
}
sort(valid,valid+len,cmp);
for(int i=0;i<len;i++)
cout<<valid[i].id<<" "<<valid[i].p<<" "<<valid[i].mid<<" "<<valid[i].fin<<" "<<valid[i].g<<endl;
return 0;
}