PAT甲级 1137. Final Grading (25)

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G = (Gmid-termx 40% + Gfinalx 60%) if Gmid-term > Gfinal, or Gfinal will be taken as the final grade G. Here Gmid-term and Gfinal are the student's scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores Gp's; the second one contains M mid-term scores Gmid-term's; and the last one contains N final exam scores Gfinal's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID Gp Gmid-term Gfinal G

If some score does not exist, output "-1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qualified student.

Sample Input:
6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81
Sample Output:
missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84
题目解析:

题目要求判断一个学生是否有资格拿到证书,这个资格需要两方面来判断:

1、输入P份在线成绩,必须不低于200分的才有资格,因此只保留满足这个条件的人就可以;

2、输入M份期中成绩和N份期末成绩,根据期中成绩和期末成绩来决定最终成绩G:(1)期末成绩大于期中成绩则用期末成绩当最终成绩G;(2)否则,用期中成绩*40%+期末成绩*60%当作最终成绩G,G>=60才有资格

此外,G的计算需要四舍五入,输出按G从大到小,再按名字的字典序,具体看程序

#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <map>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <algorithm>
#include <iostream>
using namespace std;

#define long long ll
const int MAXN = 1e4 + 10;
const int INF = 0x7fffffff;
const int dx[]={0, 1, 0, -1};
const int dy[]={1, 0, -1, 0};
int n, k;
int p, m;
map<string, int>mp;
struct NODE{
    string name;
    int scorep, scorem, scoren, scoreG;
}node[MAXN];
bool cmp(NODE x, NODE y){
    if(x.scoreG==y.scoreG) return x.name<y.name;///名字字典序
    return x.scoreG>y.scoreG;///分数从大到小
}
int main(){
    string name0;
    int score, cnt;
    while(~scanf("%d%d%d", &p, &m, &n)){
        cnt=0;mp.clear();
        for(int i=0; i<p; i++){
            cin>>name0>>score;
            if(score>=200){///在线成绩大于等于200
                mp[name0]=(++cnt), node[cnt].name=name0, node[cnt].scorep=score;
                node[cnt].scorem=-1, node[cnt].scoren=-1, node[cnt].scoreG=0;///期中期末成绩置初始值-1,最终成绩置0
            }
        }
        for(int i=0; i<m; i++){cin>>name0>>score;if(mp[name0]) node[mp[name0]].scorem=score;}///期中成绩
        for(int i=0; i<n; i++){cin>>name0>>score;if(mp[name0]) node[mp[name0]].scoren=score;}///期末成绩
        for(int i=1; i<=cnt; i++){
            if(node[i].scorem>node[i].scoren) node[i].scoreG=int(0.4*node[i].scorem+0.6*node[i].scoren+0.5);///四舍五入
            else node[i].scoreG=node[i].scoren;
        }
        sort(node+1, node+1+cnt, cmp);
        for(int i=1; i<=cnt; i++){
            if(node[i].scoreG<60) break;///最终成绩大于等于60
            cout<<node[i].name;
            printf(" %d %d %d %d\n", node[i].scorep, node[i].scorem, node[i].scoren, node[i].scoreG);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值