POJ 1488 textQuotes

TEX Quotes
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10458 Accepted: 5439

Description

TEX is a typesetting language developed by Donald Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use double-left-quote and double-right-quote to delimit quotations, rather than the mundane " which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote ` and a right-single-quote '. Check your keyboard now to locate the left-single-quote key ` (sometimes called the "backquote key") and the right-single-quote key ' (sometimes called the "apostrophe" or just "quote"). Be careful not to confuse the left-single-quote ` with the "backslash" key \. TEX lets the user type two left-single-quotes `` to create a left-double-quote and two right-single-quotes '' to create a right-double-quote. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote ". 

If the source contained 
"To be or not to be," quoth the bard, "that is the question." 
then the typeset document produced by TEX would not contain the desired form: "To be or not to be," quoth the bard, "that is the question." In order to produce the desired form, the source file must contain the sequence: 
``To be or not to be,'' quoth the bard, ``that is the question.'' 
You are to write a program which converts text containing double-quote (") characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by TEX for delimiting quotations with oriented double-quotes. The double-quote (") characters should be replaced appropriately by either `` if the " opens a quotation and by '' if the " closes a quotation. Notice that the question of nested quotations does not arise: The first " must be replaced by ``, the next by '', the next by ``, the next by '', the next by ``, the next by '', and so on. 

Input

Input will consist of several lines of text containing an even number of double-quote (") characters. Input is ended with an end-of-file character.

Output

The text must be output exactly as it was input except that: 

  • the first " in each pair is replaced by two ` characters: `` and 
  • the second " in each pair is replaced by two ' characters: ''. 

Sample Input

"To be or not to be," quoth the Bard, "that
is the question".
The programming contestant replied: "I must disagree.
To `C' or not to `C', that is The Question!"

Sample Output

``To be or not to be,'' quoth the Bard, ``that
is the question''.
The programming contestant replied: ``I must disagree.
To `C' or not to `C', that is The Question!''

这道题使用C++string 类实现极为简单
#include <iostream>
#include <algorithm>
#include <string>

using namespace std;

int main()
{
    string s;
    int i=0;
    while(getline(cin,s))
    {
        int loc=0;
        do{
            loc=s.find('\"',loc);//find()函数,若能够找到,则返回该字符所在的下标,否则返回string::npos--(代表的是字符串的终结位置)
            i++;
            if(loc==string::npos)
            {
                i--;
                break;
            }
            if(i%2==0)
                s.replace(loc, 1, "''");//代替函数,用''自负代替从loc开始 一个长度的字符
            else
                s.replace(loc, 1, "``");
        }while(loc!=string::npos);
        cout<<s<<endl;
    }
    return 0;
}
如果想要了解更多的关于string 类中的操作函数可以进入如下链接
http://blog.csdn.net/weixin_37571609/article/details/66970886


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值