POJ 1007 DNA Sorting

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 100796 Accepted: 40442

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
//题目要求是对固定长度的字符串进行排序,当然排序的前提是按照每个字符串内部 使字符达到有序条件的时候需要的转置交换次数按照从大到小对所有字符串进行排序,暴力解法直接计算出每个字符串需要进行的转置次数
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
struct node{ //结构体存储字符串,s是读入以及进行交换的字符串,s2存储原字符串方便输出,inver统计交换次数
    string s;
    string s2;
    int inver;
};
bool cmp(node n1,node n2)//使排序函数降序排列
{
    return n1.inver<n2.inver;
}
int main(int argc, const char * argv[]) {
    int len,num;
    cin>>len>>num;
    node t[100];
    
    int i=0;
    char c;
    while(i<num)
    {
        cin>>t[i].s;
        t[i].s2=t[i].s;
        t[i].inver=0;
        for(int k=0;k<len-1;k++)
            for(int j=0;j<len-1;j++)
                if(t[i].s[j]>t[i].s[j+1])
                {
                    c=t[i].s[j];
                    t[i].s[j]=t[i].s[j+1];
                    t[i].s[j+1]=c;
                    t[i].inver++;
                }
        i++;
    }
    sort(t,t+num,cmp);
    for(int i=0;i<num;i++)
        cout<<t[i].s2<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值