POJ 1396 All in All

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 33147 Accepted: 13810

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No
//题目要求后一个输入的字符串必须包含前一个字符串才可以输出“Yes”,而且这种包含是按照前一个字符串中字符的顺序包含的。否则输出“No”。
//可以利用循环对应字符比较,相等的话同时累加,否则累加后一个字符串,也可以利用将后一个字符串中包含的前一个字符串赋值给一个新的字符串,最后比较新的字符串和第一个字符串是否相等,利用int loc=find(char c,int pos=0)。
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
int main(int argc, const char * argv[]) {
    string s1,s2;
    while(cin>>s1>>s2)
    {
        int i=0,j=0;
        for(;i<s1.size()&&j<s2.size();)
            if(s1[i]==s2[j])
                i++,j++;
            else
                j++;
        if(i<s1.size())
            cout<<"No"<<endl;
        else
            cout<<"Yes"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值