HDU 1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50112    Accepted Submission(s): 22094


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
//很显然是搜索类题目,常用的就是深搜和广搜,但是针对这一道题目,采用深搜比较方便,广搜的话貌似写不出来,如果有大佬可以做出来,麻烦分享分享。。。。深搜的话,对每个符合要求,即最后的结果构成一个环,环之间的数相邻的话俩俩互质。代码如下450MS,由0MS的可以分享分享:
#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
int a[21];
int b[21];
int n;
bool prime(int n)
{
    int i;
    for(i = 2;i <= n/2; ++i)
        if(n % i == 0)
            return 0;
    return 1;
}
void dfs(int step)//深搜开始
{
    if(step == n+1)
    {
        if(!prime(a[n] + 1) )//如果在到达n+1之前与环首1相加不是素数,什么也不输出,结束
            return ;
        for(int i = 1;i <= n; ++i)
        {
            cout << a[i];
            if(i != n)
                cout << " ";
            else
                cout << endl;
        }
    }
    for(int i = 2;i <= n; ++i)
    {
        if(b[i] == 0 && prime(a[step - 1] + i))//未访问且满足相邻元素元素为素数
        {
            b[i] = 1;
            a[step] = i;//将满足的i 放入对应序列的数组
            dfs(step + 1);//递归调用
            b[i] = 0;//为了下一个满足条件的所有数列的输出,重置为0
        }
    }
    return ;
}
int main(int argc, const char * argv[]) {
    int i = 1;
    while(cin >> n)
    {
        for (int i = 2; i<=n;i++)
        {
            b[i] =0;
            a[i] = 0;
        }
        a[1] = 1;
        b[1] = 1;
        cout << "Case " << i++ << ":" << endl;
        dfs(2);//a[1] = 1,那么数组缺少的是从a[2] 以后的元素
        cout << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值